diff options
author | David Shaw <[email protected]> | 2004-12-30 03:31:19 +0000 |
---|---|---|
committer | David Shaw <[email protected]> | 2004-12-30 03:31:19 +0000 |
commit | 2193ab9fc7c55d12aad5160755bca3e5de40546a (patch) | |
tree | d0dd3c9700ce199156d03b0ce1fce92d35491151 | |
parent | * packet.h, getkey.c (merge_selfsigs_main, sig_to_revoke_info), keyid.c (diff) | |
download | gnupg-2193ab9fc7c55d12aad5160755bca3e5de40546a.tar.gz gnupg-2193ab9fc7c55d12aad5160755bca3e5de40546a.zip |
* configure.ac: Better implementation for the SRV check. We don't need to
actually check all the header files individually since the SRV test
compile uses them together.
-rw-r--r-- | ChangeLog | 6 | ||||
-rw-r--r-- | configure.ac | 6 |
2 files changed, 8 insertions, 4 deletions
@@ -1,3 +1,9 @@ +2004-12-28 David Shaw <[email protected]> + + * configure.ac: Better implementation for the SRV check. We don't + need to actually check all the header files individually since the + SRV test compile uses them together. + 2004-12-24 David Shaw <[email protected]> * configure.ac: Use new LIBCURL_CHECK_CONFIG macro for diff --git a/configure.ac b/configure.ac index 6b2f5bd9c..ed1983999 100644 --- a/configure.ac +++ b/configure.ac @@ -572,9 +572,8 @@ if (test x"$try_hkp" = xyes || test x"$try_http" = xyes) && test x"$use_dns_srv" if test x"$use_dns_srv" = xyes ; then AC_DEFINE(USE_DNS_SRV,1,[define to use DNS SRV]) SRVLIBS=$LIBS - else - AC_MSG_NOTICE([Resolver functions not found or not usable. Disabling DNS SRV.]) fi + LIBS=$_srv_save_libs fi @@ -804,13 +803,12 @@ AM_CONDITIONAL(ENABLE_CARD_SUPPORT, test "$card_support" = yes) dnl Checks for header files. AC_HEADER_STDC -AC_CHECK_HEADERS([unistd.h langinfo.h termio.h locale.h getopt.h arpa/nameser.h]) +AC_CHECK_HEADERS([unistd.h langinfo.h termio.h locale.h getopt.h]) # Note that we do not check for iconv here because this is done anyway # by the gettext checks and thus it allows us to disable the use of # iconv by using --disable-nls. - dnl Checks for typedefs, structures, and compiler characteristics. AC_C_CONST AC_C_INLINE |