aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2005-07-28 19:30:13 +0000
committerWerner Koch <[email protected]>2005-07-28 19:30:13 +0000
commit1d139c8147166ebec799ef5f1d5d5b8baced30d6 (patch)
tree20ef3d014fbdbd1d0a08c099d068701ecb90c188
parentImplemented PKA trust model (diff)
downloadgnupg-1d139c8147166ebec799ef5f1d5d5b8baced30d6.tar.gz
gnupg-1d139c8147166ebec799ef5f1d5d5b8baced30d6.zip
Implemented PKA trust model
-rw-r--r--util/ChangeLog2
-rw-r--r--util/pka.c4
2 files changed, 4 insertions, 2 deletions
diff --git a/util/ChangeLog b/util/ChangeLog
index fd181172c..ec3b31161 100644
--- a/util/ChangeLog
+++ b/util/ChangeLog
@@ -1,6 +1,8 @@
2005-07-28 Werner Koch <[email protected]>
* pka.c: New.
+ (parse_txt_record): Changed from v=1 to v=pka1.
+
* Makefile.am (pka-test): new.
2005-07-27 Werner Koch <[email protected]>
diff --git a/util/pka.c b/util/pka.c
index 95689e02b..3c9e5c437 100644
--- a/util/pka.c
+++ b/util/pka.c
@@ -44,7 +44,7 @@
#ifdef USE_DNS_PKA
/* Parse the TXT resource record. Format is:
- v=1;fpr=a4d94e92b0986ab5ee9dcd755de249965b0358a2;uri=string
+ v=pka1;fpr=a4d94e92b0986ab5ee9dcd755de249965b0358a2;uri=string
For simplicity white spaces are not allowed. Because we expect to
use a new RRTYPE for this in the future we define the TXT really
@@ -66,7 +66,7 @@ parse_txt_record (char *buffer, unsigned char *fpr)
if (!pend)
return -1;
*pend++ = 0;
- if (strcmp (p, "v=1"))
+ if (strcmp (p, "v=pka1"))
return -1; /* Wrong or missing version. */
p = pend;