aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2015-04-24 14:42:28 +0000
committerWerner Koch <[email protected]>2015-04-24 14:42:28 +0000
commit172b6193488f433a206fd88f85d8c4a5d1eb7fdf (patch)
treef29c173aacc6be4f517e92ca3da8c10dbd73c35b
parentcommon: Rename log and gcc attribute macros (jnlib merge). (diff)
downloadgnupg-172b6193488f433a206fd88f85d8c4a5d1eb7fdf.tar.gz
gnupg-172b6193488f433a206fd88f85d8c4a5d1eb7fdf.zip
common: Remove JNLIB from boiler plate (jnlib merge).
* common/README.jnlib: Remove. -- This is the final part of merging jnlib into gnupg/common.
-rw-r--r--common/ChangeLog.jnlib3
-rw-r--r--common/Makefile.am2
-rw-r--r--common/README.jnlib99
-rw-r--r--common/argparse.c6
-rw-r--r--common/argparse.h12
-rw-r--r--common/dotlock.c6
-rw-r--r--common/dotlock.h12
-rw-r--r--common/dynload.h12
-rw-r--r--common/logging.c6
-rw-r--r--common/logging.h12
-rw-r--r--common/mischelp.c6
-rw-r--r--common/mischelp.h12
-rw-r--r--common/stringhelp.c6
-rw-r--r--common/stringhelp.h12
-rw-r--r--common/strlist.c6
-rw-r--r--common/strlist.h12
-rw-r--r--common/t-stringhelp.c6
-rw-r--r--common/t-support.c6
-rw-r--r--common/t-support.h12
-rw-r--r--common/t-timestuff.c6
-rw-r--r--common/t-w32-reg.c6
-rw-r--r--common/types.h12
-rw-r--r--common/utf8conv.c6
-rw-r--r--common/utf8conv.h12
-rw-r--r--common/util.h6
-rw-r--r--common/w32-afunix.c6
-rw-r--r--common/w32-afunix.h6
-rw-r--r--common/w32-reg.c6
-rw-r--r--common/w32help.h12
-rw-r--r--common/xmalloc.c6
-rw-r--r--common/xmalloc.h12
31 files changed, 124 insertions, 220 deletions
diff --git a/common/ChangeLog.jnlib b/common/ChangeLog.jnlib
index 4ac02f3c2..6c0db1307 100644
--- a/common/ChangeLog.jnlib
+++ b/common/ChangeLog.jnlib
@@ -5,6 +5,9 @@
commit log, and generate a top-level ChangeLog file from logs at
"make dist". See doc/HACKING for details.
+ [Update 2015-04-24: README.jnlib has been removed and all
+ references to JNLIB, except for this file, have been removed.]
+
2010-03-10 Werner Koch <[email protected]>
See gnupg/common/ChangeLog for newer changes.
diff --git a/common/Makefile.am b/common/Makefile.am
index 45aaede1d..c0df5ef8d 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -19,7 +19,7 @@
## Process this file with automake to produce Makefile.in
EXTRA_DIST = mkstrtable.awk exaudit.awk exstatus.awk ChangeLog-2011 \
- audit-events.h status-codes.h README.jnlib ChangeLog.jnlib \
+ audit-events.h status-codes.h ChangeLog.jnlib \
ChangeLog-2011.include w32info-rc.h.in gnupg.ico tls-ca.pem
noinst_LIBRARIES = libcommon.a libcommonpth.a libgpgrl.a \
diff --git a/common/README.jnlib b/common/README.jnlib
deleted file mode 100644
index 50a29257e..000000000
--- a/common/README.jnlib
+++ /dev/null
@@ -1,99 +0,0 @@
-JNLIB - This is a collection of utility function which are too small
-to put into a library. The code here is licensed under the LGPL.
-
-libjnlib-config.h should be be modified for each project to make these
-functions fit into the software. Mainly these are memory functions in
-case you need another allocator.
-
-Files which make up jnlib:
- README.jnlib
- ChangeLog.jnlib
- libjnlib-config.h
- argparse.c
- argparse.h
- dotlock.c
- dotlock.h
- dynload.h
- logging.c
- logging.h
- mischelp.c
- mischelp.h
- stringhelp.c
- stringhelp.h
- strlist.c
- strlist.h
- types.h
- utf8conv.c
- utf8conv.h
- w32-afunix.c
- w32-afunix.h
- w32-reg.c
- w32help.h
- xmalloc.c
- xmalloc.h
- t-stringhelp.c
- t-support.c
- t-support.h
- t-timestuff.c
- t-w32-reg.c
-
-
-Here is a template Makefile.am for these jnlib modules:
-===8<==================================================
-EXTRA_DIST = README
-noinst_PROGRAMS = $(module_tests)
-TESTS = $(module_tests)
-
-AM_CPPFLAGS = -I$(top_srcdir)/intl
-
-# We need libgcrypt because libjnlib-config includes gcrypt.h
-AM_CFLAGS = $(LIBGCRYPT_CFLAGS)
-
-noinst_LIBRARIES = libjnlib.a
-
-libjnlib_a_SOURCES = \
- libjnlib-config.h \
- stringhelp.c stringhelp.h \
- strlist.c strlist.h \
- utf8conv.c utf8conv.h \
- argparse.c argparse.h \
- logging.c logging.h \
- dotlock.c dotlock.h \
- types.h mischelp.c mischelp.h dynload.h w32help.h \
- xmalloc.c xmalloc.h
-
-if HAVE_W32_SYSTEM
-libjnlib_a_SOURCES += w32-reg.c w32-afunix.c w32-afunix.h
-endif
-
-#
-# Module tests.
-#
-# These tests should only be used at the canonical location of jnlib
-# which is the GnuPG package. The reason for this is that t-support.c
-# defines replacements for the actual used memory allocation functions
-# so that there is no dependency on libgcrypt.
-#
-module_tests = t-stringhelp t-timestuff
-if HAVE_W32_SYSTEM
-module_tests += t-w32-reg
-endif
-
-t_jnlib_src = t-support.c t-support.h
-t_jnlib_ldadd = libjnlib.a $(LIBINTL) $(LIBICONV)
-# For W32 we need libgpg-error because it provides gettext.
-if HAVE_W32_SYSTEM
-t_jnlib_ldadd += $(GPG_ERROR_LIBS)
-endif
-
-t_stringhelp_SOURCES = t-stringhelp.c $(t_jnlib_src)
-t_stringhelp_LDADD = $(t_jnlib_ldadd)
-
-t_timestuff_SOURCES = t-timestuff.c $(t_jnlib_src)
-t_timestuff_LDADD = $(t_jnlib_ldadd)
-
-if HAVE_W32_SYSTEM
-t_w32_reg_SOURCES = t-w32-reg.c $(t_jnlib_src)
-t_w32_reg_LDADD = $(t_jnlib_ldadd)
-endif
-==>8===================================================
diff --git a/common/argparse.c b/common/argparse.c
index 94ba71d27..e9d98f063 100644
--- a/common/argparse.c
+++ b/common/argparse.c
@@ -2,9 +2,9 @@
* Copyright (C) 1998-2001, 2006-2008, 2012 Free Software Foundation, Inc.
* Copyright (C) 1997-2001, 2006-2008, 2013-2015 Werner Koch
*
- * This file is part of JNLIB, which is a subsystem of GnuPG.
+ * This file is part of GnuPG.
*
- * JNLIB is free software; you can redistribute it and/or modify it
+ * GnuPG is free software; you can redistribute it and/or modify it
* under the terms of either
*
* - the GNU Lesser General Public License as published by the Free
@@ -19,7 +19,7 @@
*
* or both in parallel, as here.
*
- * JNLIB is distributed in the hope that it will be useful, but
+ * GnuPG is distributed in the hope that it will be useful, but
* WITHOUT ANY WARRANTY; without even the implied warranty of
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
* General Public License for more details.
diff --git a/common/argparse.h b/common/argparse.h
index b4dc25373..10b838fef 100644
--- a/common/argparse.h
+++ b/common/argparse.h
@@ -1,9 +1,9 @@
/* argparse.h - Argument parser for option handling.
* Copyright (C) 1998,1999,2000,2001,2006 Free Software Foundation, Inc.
*
- * This file is part of JNLIB, which is a subsystem of GnuPG.
+ * This file is part of GnuPG.
*
- * JNLIB is free software; you can redistribute it and/or modify it
+ * GnuPG is free software; you can redistribute it and/or modify it
* under the terms of either
*
* - the GNU Lesser General Public License as published by the Free
@@ -18,7 +18,7 @@
*
* or both in parallel, as here.
*
- * JNLIB is distributed in the hope that it will be useful, but
+ * GnuPG is distributed in the hope that it will be useful, but
* WITHOUT ANY WARRANTY; without even the implied warranty of
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
* General Public License for more details.
@@ -28,8 +28,8 @@
* if not, see <http://www.gnu.org/licenses/>.
*/
-#ifndef LIBJNLIB_ARGPARSE_H
-#define LIBJNLIB_ARGPARSE_H
+#ifndef GNUPG_COMMON_ARGPARSE_H
+#define GNUPG_COMMON_ARGPARSE_H
#include <stdio.h>
@@ -200,4 +200,4 @@ const char *strusage (int level);
void set_strusage (const char *(*f)( int ));
void argparse_register_outfnc (int (*fnc)(int, const char *));
-#endif /*LIBJNLIB_ARGPARSE_H*/
+#endif /*GNUPG_COMMON_ARGPARSE_H*/
diff --git a/common/dotlock.c b/common/dotlock.c
index 573456f00..bccd0c69f 100644
--- a/common/dotlock.c
+++ b/common/dotlock.c
@@ -2,9 +2,9 @@
* Copyright (C) 1998, 2000, 2001, 2003, 2004,
* 2005, 2006, 2008, 2010, 2011 Free Software Foundation, Inc.
*
- * This file is part of JNLIB, which is a subsystem of GnuPG.
+ * This file is part of GnuPG.
*
- * JNLIB is free software; you can redistribute it and/or modify it
+ * GnuPG is free software; you can redistribute it and/or modify it
* under the terms of either
*
* - the GNU Lesser General Public License as published by the Free
@@ -19,7 +19,7 @@
*
* or both in parallel, as here.
*
- * JNLIB is distributed in the hope that it will be useful, but
+ * GnuPG is distributed in the hope that it will be useful, but
* WITHOUT ANY WARRANTY; without even the implied warranty of
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
* General Public License for more details.
diff --git a/common/dotlock.h b/common/dotlock.h
index 3fb9bcb21..c317c379a 100644
--- a/common/dotlock.h
+++ b/common/dotlock.h
@@ -1,9 +1,9 @@
/* dotlock.h - dotfile locking declarations
* Copyright (C) 2000, 2001, 2006, 2011 Free Software Foundation, Inc.
*
- * This file is part of JNLIB, which is a subsystem of GnuPG.
+ * This file is part of GnuPG.
*
- * JNLIB is free software; you can redistribute it and/or modify it
+ * GnuPG is free software; you can redistribute it and/or modify it
* under the terms of either
*
* - the GNU Lesser General Public License as published by the Free
@@ -18,7 +18,7 @@
*
* or both in parallel, as here.
*
- * JNLIB is distributed in the hope that it will be useful, but
+ * GnuPG is distributed in the hope that it will be useful, but
* WITHOUT ANY WARRANTY; without even the implied warranty of
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
* General Public License for more details.
@@ -64,8 +64,8 @@
* OF THE POSSIBILITY OF SUCH DAMAGE.
*/
-#ifndef LIBJNLIB_DOTLOCK_H
-#define LIBJNLIB_DOTLOCK_H
+#ifndef GNUPG_COMMON_DOTLOCK_H
+#define GNUPG_COMMON_DOTLOCK_H
/* See dotlock.c for a description. */
@@ -109,4 +109,4 @@ void dotlock_remove_lockfiles (void);
#ifdef __cplusplus
}
#endif
-#endif /*LIBJNLIB_DOTLOCK_H*/
+#endif /*GNUPG_COMMON_DOTLOCK_H*/
diff --git a/common/dynload.h b/common/dynload.h
index 1d7966e60..6ba02ffc0 100644
--- a/common/dynload.h
+++ b/common/dynload.h
@@ -1,9 +1,9 @@
/* dynload.h - Wrapper functions for run-time dynamic loading
* Copyright (C) 2003, 2010 Free Software Foundation, Inc.
*
- * This file is part of JNLIB, which is a subsystem of GnuPG.
+ * This file is part of GnuPG.
*
- * JNLIB is free software; you can redistribute it and/or modify it
+ * GnuPG is free software; you can redistribute it and/or modify it
* under the terms of either
*
* - the GNU Lesser General Public License as published by the Free
@@ -18,7 +18,7 @@
*
* or both in parallel, as here.
*
- * JNLIB is distributed in the hope that it will be useful, but
+ * GnuPG is distributed in the hope that it will be useful, but
* WITHOUT ANY WARRANTY; without even the implied warranty of
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
* General Public License for more details.
@@ -28,8 +28,8 @@
* if not, see <http://www.gnu.org/licenses/>.
*/
-#ifndef LIBJNLIB_DYNLOAD_H
-#define LIBJNLIB_DYNLOAD_H
+#ifndef GNUPG_COMMON_DYNLOAD_H
+#define GNUPG_COMMON_DYNLOAD_H
#ifndef __MINGW32__
# include <dlfcn.h>
@@ -94,4 +94,4 @@ dlclose (void * hd)
return -1;
}
# endif /*__MINGW32__*/
-#endif /*LIBJNLIB_DYNLOAD_H*/
+#endif /*GNUPG_COMMON_DYNLOAD_H*/
diff --git a/common/logging.c b/common/logging.c
index f4dfc1522..2932c3dea 100644
--- a/common/logging.c
+++ b/common/logging.c
@@ -2,9 +2,9 @@
* Copyright (C) 1998, 1999, 2000, 2001, 2003, 2004, 2005, 2006,
* 2009, 2010 Free Software Foundation, Inc.
*
- * This file is part of JNLIB, which is a subsystem of GnuPG.
+ * This file is part of GnuPG.
*
- * JNLIB is free software; you can redistribute it and/or modify it
+ * GnuPG is free software; you can redistribute it and/or modify it
* under the terms of either
*
* - the GNU Lesser General Public License as published by the Free
@@ -19,7 +19,7 @@
*
* or both in parallel, as here.
*
- * JNLIB is distributed in the hope that it will be useful, but
+ * GnuPG is distributed in the hope that it will be useful, but
* WITHOUT ANY WARRANTY; without even the implied warranty of
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
* General Public License for more details.
diff --git a/common/logging.h b/common/logging.h
index 477b9b3f3..0bd1a6c7f 100644
--- a/common/logging.h
+++ b/common/logging.h
@@ -2,9 +2,9 @@
* Copyright (C) 1999, 2000, 2001, 2004, 2006,
* 2010 Free Software Foundation, Inc.
*
- * This file is part of JNLIB, which is a subsystem of GnuPG.
+ * This file is part of GnuPG.
*
- * JNLIB is free software; you can redistribute it and/or modify it
+ * GnuPG is free software; you can redistribute it and/or modify it
* under the terms of either
*
* - the GNU Lesser General Public License as published by the Free
@@ -19,7 +19,7 @@
*
* or both in parallel, as here.
*
- * JNLIB is distributed in the hope that it will be useful, but
+ * GnuPG is distributed in the hope that it will be useful, but
* WITHOUT ANY WARRANTY; without even the implied warranty of
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
* General Public License for more details.
@@ -29,8 +29,8 @@
* if not, see <http://www.gnu.org/licenses/>.
*/
-#ifndef LIBJNLIB_LOGGING_H
-#define LIBJNLIB_LOGGING_H
+#ifndef GNUPG_COMMON_LOGGING_H
+#define GNUPG_COMMON_LOGGING_H
#include <stdio.h>
#include <stdarg.h>
@@ -96,4 +96,4 @@ void log_printhex (const char *text, const void *buffer, size_t length);
void log_clock (const char *string);
-#endif /*LIBJNLIB_LOGGING_H*/
+#endif /*GNUPG_COMMON_LOGGING_H*/
diff --git a/common/mischelp.c b/common/mischelp.c
index c6ad38798..566219192 100644
--- a/common/mischelp.c
+++ b/common/mischelp.c
@@ -1,9 +1,9 @@
/* mischelp.c - Miscellaneous helper functions
* Copyright (C) 1998, 2000, 2001, 2006, 2007 Free Software Foundation, Inc.
*
- * This file is part of JNLIB, which is a subsystem of GnuPG.
+ * This file is part of GnuPG.
*
- * JNLIB is free software; you can redistribute it and/or modify it
+ * GnuPG is free software; you can redistribute it and/or modify it
* under the terms of either
*
* - the GNU Lesser General Public License as published by the Free
@@ -18,7 +18,7 @@
*
* or both in parallel, as here.
*
- * JNLIB is distributed in the hope that it will be useful, but
+ * GnuPG is distributed in the hope that it will be useful, but
* WITHOUT ANY WARRANTY; without even the implied warranty of
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
* General Public License for more details.
diff --git a/common/mischelp.h b/common/mischelp.h
index 940651f5e..ecbf38b5c 100644
--- a/common/mischelp.h
+++ b/common/mischelp.h
@@ -2,9 +2,9 @@
* Copyright (C) 1999, 2000, 2001, 2002, 2003,
* 2006, 2007, 2009 Free Software Foundation, Inc.
*
- * This file is part of JNLIB, which is a subsystem of GnuPG.
+ * This file is part of GnuPG.
*
- * JNLIB is free software; you can redistribute it and/or modify it
+ * GnuPG is free software; you can redistribute it and/or modify it
* under the terms of either
*
* - the GNU Lesser General Public License as published by the Free
@@ -19,7 +19,7 @@
*
* or both in parallel, as here.
*
- * JNLIB is distributed in the hope that it will be useful, but
+ * GnuPG is distributed in the hope that it will be useful, but
* WITHOUT ANY WARRANTY; without even the implied warranty of
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
* General Public License for more details.
@@ -29,8 +29,8 @@
* if not, see <http://www.gnu.org/licenses/>.
*/
-#ifndef LIBJNLIB_MISCHELP_H
-#define LIBJNLIB_MISCHELP_H
+#ifndef GNUPG_COMMON_MISCHELP_H
+#define GNUPG_COMMON_MISCHELP_H
/* Check whether the files NAME1 and NAME2 are identical. This is for
@@ -118,4 +118,4 @@ time_t timegm (struct tm *tm);
#endif /*GNUPG_COMMON_NEED_AFLOCAL*/
-#endif /*LIBJNLIB_MISCHELP_H*/
+#endif /*GNUPG_COMMON_MISCHELP_H*/
diff --git a/common/stringhelp.c b/common/stringhelp.c
index 96710bfd4..ca8ae0bbc 100644
--- a/common/stringhelp.c
+++ b/common/stringhelp.c
@@ -4,9 +4,9 @@
* Copyright (C) 2014 Werner Koch
* Copyright (C) 2015 g10 Code GmbH
*
- * This file is part of JNLIB, which is a subsystem of GnuPG.
+ * This file is part of GnuPG.
*
- * JNLIB is free software; you can redistribute it and/or modify it
+ * GnuPG is free software; you can redistribute it and/or modify it
* under the terms of either
*
* - the GNU Lesser General Public License as published by the Free
@@ -21,7 +21,7 @@
*
* or both in parallel, as here.
*
- * JNLIB is distributed in the hope that it will be useful, but
+ * GnuPG is distributed in the hope that it will be useful, but
* WITHOUT ANY WARRANTY; without even the implied warranty of
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
* General Public License for more details.
diff --git a/common/stringhelp.h b/common/stringhelp.h
index 864a6893b..b9b51fd9c 100644
--- a/common/stringhelp.h
+++ b/common/stringhelp.h
@@ -3,9 +3,9 @@
* 2006, 2007, 2009 Free Software Foundation, Inc.
* 2015 g10 Code GmbH
*
- * This file is part of JNLIB, which is a subsystem of GnuPG.
+ * This file is part of GnuPG.
*
- * JNLIB is free software; you can redistribute it and/or modify it
+ * GnuPG is free software; you can redistribute it and/or modify it
* under the terms of either
*
* - the GNU Lesser General Public License as published by the Free
@@ -20,7 +20,7 @@
*
* or both in parallel, as here.
*
- * JNLIB is distributed in the hope that it will be useful, but
+ * GnuPG is distributed in the hope that it will be useful, but
* WITHOUT ANY WARRANTY; without even the implied warranty of
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
* General Public License for more details.
@@ -30,8 +30,8 @@
* if not, see <http://www.gnu.org/licenses/>.
*/
-#ifndef LIBJNLIB_STRINGHELP_H
-#define LIBJNLIB_STRINGHELP_H
+#ifndef GNUPG_COMMON_STRINGHELP_H
+#define GNUPG_COMMON_STRINGHELP_H
#include "types.h"
@@ -148,4 +148,4 @@ char **strsplit (char *string, char delim, char replacement, int *count);
/*-- mapstrings.c --*/
const char *map_static_macro_string (const char *string);
-#endif /*LIBJNLIB_STRINGHELP_H*/
+#endif /*GNUPG_COMMON_STRINGHELP_H*/
diff --git a/common/strlist.c b/common/strlist.c
index e29fd468e..967509c56 100644
--- a/common/strlist.c
+++ b/common/strlist.c
@@ -2,9 +2,9 @@
* Copyright (C) 1998, 2000, 2001, 2006 Free Software Foundation, Inc.
* Copyright (C) 2015 g10 Code GmbH
*
- * This file is part of JNLIB, which is a subsystem of GnuPG.
+ * This file is part of GnuPG.
*
- * JNLIB is free software; you can redistribute it and/or modify it
+ * GnuPG is free software; you can redistribute it and/or modify it
* under the terms of either
*
* - the GNU Lesser General Public License as published by the Free
@@ -19,7 +19,7 @@
*
* or both in parallel, as here.
*
- * JNLIB is distributed in the hope that it will be useful, but
+ * GnuPG is distributed in the hope that it will be useful, but
* WITHOUT ANY WARRANTY; without even the implied warranty of
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
* General Public License for more details.
diff --git a/common/strlist.h b/common/strlist.h
index 94567df0a..5c17ce69f 100644
--- a/common/strlist.h
+++ b/common/strlist.h
@@ -1,9 +1,9 @@
/* strlist.h
* Copyright (C) 1998, 2000, 2001, 2006 Free Software Foundation, Inc.
*
- * This file is part of JNLIB, which is a subsystem of GnuPG.
+ * This file is part of GnuPG.
*
- * JNLIB is free software; you can redistribute it and/or modify it
+ * GnuPG is free software; you can redistribute it and/or modify it
* under the terms of either
*
* - the GNU Lesser General Public License as published by the Free
@@ -18,7 +18,7 @@
*
* or both in parallel, as here.
*
- * JNLIB is distributed in the hope that it will be useful, but
+ * GnuPG is distributed in the hope that it will be useful, but
* WITHOUT ANY WARRANTY; without even the implied warranty of
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
* General Public License for more details.
@@ -28,8 +28,8 @@
* if not, see <http://www.gnu.org/licenses/>.
*/
-#ifndef LIBJNLIB_STRLIST_H
-#define LIBJNLIB_STRLIST_H
+#ifndef GNUPG_COMMON_STRLIST_H
+#define GNUPG_COMMON_STRLIST_H
struct string_list
{
@@ -61,4 +61,4 @@ strlist_t strlist_find (strlist_t haystack, const char *needle);
#define FREE_STRLIST(a) do { free_strlist((a)); (a) = NULL ; } while(0)
-#endif /*LIBJNLIB_STRLIST_H*/
+#endif /*GNUPG_COMMON_STRLIST_H*/
diff --git a/common/t-stringhelp.c b/common/t-stringhelp.c
index 9d1d20c96..6c4723754 100644
--- a/common/t-stringhelp.c
+++ b/common/t-stringhelp.c
@@ -2,9 +2,9 @@
* Copyright (C) 2007 Free Software Foundation, Inc.
* 2015 g10 Code GmbH
*
- * This file is part of JNLIB, which is a subsystem of GnuPG.
+ * This file is part of GnuPG.
*
- * JNLIB is free software; you can redistribute it and/or modify it
+ * GnuPG is free software; you can redistribute it and/or modify it
* under the terms of either
*
* - the GNU Lesser General Public License as published by the Free
@@ -19,7 +19,7 @@
*
* or both in parallel, as here.
*
- * JNLIB is distributed in the hope that it will be useful, but
+ * GnuPG is distributed in the hope that it will be useful, but
* WITHOUT ANY WARRANTY; without even the implied warranty of
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
* General Public License for more details.
diff --git a/common/t-support.c b/common/t-support.c
index aa95a06d8..7dd8f0afe 100644
--- a/common/t-support.c
+++ b/common/t-support.c
@@ -1,9 +1,9 @@
/* t-support.c - helper functions for the regression tests.
* Copyright (C) 2007 Free Software Foundation, Inc.
*
- * This file is part of JNLIB, which is a subsystem of GnuPG.
+ * This file is part of GnuPG.
*
- * JNLIB is free software; you can redistribute it and/or modify it
+ * GnuPG is free software; you can redistribute it and/or modify it
* under the terms of either
*
* - the GNU Lesser General Public License as published by the Free
@@ -18,7 +18,7 @@
*
* or both in parallel, as here.
*
- * JNLIB is distributed in the hope that it will be useful, but
+ * GnuPG is distributed in the hope that it will be useful, but
* WITHOUT ANY WARRANTY; without even the implied warranty of
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
* General Public License for more details.
diff --git a/common/t-support.h b/common/t-support.h
index 0dfcc7a40..555158e26 100644
--- a/common/t-support.h
+++ b/common/t-support.h
@@ -1,9 +1,9 @@
/* t-support.h - Helper for the regression tests
* Copyright (C) 2007 Free Software Foundation, Inc.
*
- * This file is part of JNLIB, which is a subsystem of GnuPG.
+ * This file is part of GnuPG.
*
- * JNLIB is free software; you can redistribute it and/or modify it
+ * GnuPG is free software; you can redistribute it and/or modify it
* under the terms of either
*
* - the GNU Lesser General Public License as published by the Free
@@ -18,7 +18,7 @@
*
* or both in parallel, as here.
*
- * JNLIB is distributed in the hope that it will be useful, but
+ * GnuPG is distributed in the hope that it will be useful, but
* WITHOUT ANY WARRANTY; without even the implied warranty of
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
* General Public License for more details.
@@ -28,8 +28,8 @@
* if not, see <http://www.gnu.org/licenses/>.
*/
-#ifndef LIBJNLIB_T_SUPPORT_H
-#define LIBJNLIB_T_SUPPORT_H 1
+#ifndef GNUPG_COMMON_T_SUPPORT_H
+#define GNUPG_COMMON_T_SUPPORT_H 1
#ifdef GCRYPT_VERSION
#error The regression tests should not include with gcrypt.h
@@ -73,4 +73,4 @@ void gcry_free (void *a);
} while(0)
-#endif /*LIBJNLIB_T_SUPPORT_H*/
+#endif /*GNUPG_COMMON_T_SUPPORT_H*/
diff --git a/common/t-timestuff.c b/common/t-timestuff.c
index 8059a875a..cb7cd392a 100644
--- a/common/t-timestuff.c
+++ b/common/t-timestuff.c
@@ -1,9 +1,9 @@
/* t-timestuff.c - Regression tests for time functions
* Copyright (C) 2007 Free Software Foundation, Inc.
*
- * This file is part of JNLIB, which is a subsystem of GnuPG.
+ * This file is part of GnuPG.
*
- * JNLIB is free software; you can redistribute it and/or modify it
+ * GnuPG is free software; you can redistribute it and/or modify it
* under the terms of either
*
* - the GNU Lesser General Public License as published by the Free
@@ -18,7 +18,7 @@
*
* or both in parallel, as here.
*
- * JNLIB is distributed in the hope that it will be useful, but
+ * GnuPG is distributed in the hope that it will be useful, but
* WITHOUT ANY WARRANTY; without even the implied warranty of
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
* General Public License for more details.
diff --git a/common/t-w32-reg.c b/common/t-w32-reg.c
index cac6db031..a26afe9f8 100644
--- a/common/t-w32-reg.c
+++ b/common/t-w32-reg.c
@@ -1,9 +1,9 @@
/* t-w32-reg.c - Regression tests for W32 registry functions
* Copyright (C) 2010 Free Software Foundation, Inc.
*
- * This file is part of JNLIB, which is a subsystem of GnuPG.
+ * This file is part of GnuPG.
*
- * JNLIB is free software; you can redistribute it and/or modify it
+ * GnuPG is free software; you can redistribute it and/or modify it
* under the terms of either
*
* - the GNU Lesser General Public License as published by the Free
@@ -18,7 +18,7 @@
*
* or both in parallel, as here.
*
- * JNLIB is distributed in the hope that it will be useful, but
+ * GnuPG is distributed in the hope that it will be useful, but
* WITHOUT ANY WARRANTY; without even the implied warranty of
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
* General Public License for more details.
diff --git a/common/types.h b/common/types.h
index 97cedc2e9..8d7730b2e 100644
--- a/common/types.h
+++ b/common/types.h
@@ -1,9 +1,9 @@
/* types.h - define some extra types
* Copyright (C) 1999, 2000, 2001, 2006 Free Software Foundation, Inc.
*
- * This file is part of JNLIB, which is a subsystem of GnuPG.
+ * This file is part of GnuPG.
*
- * JNLIB is free software; you can redistribute it and/or modify it
+ * GnuPG is free software; you can redistribute it and/or modify it
* under the terms of either
*
* - the GNU Lesser General Public License as published by the Free
@@ -18,7 +18,7 @@
*
* or both in parallel, as here.
*
- * JNLIB is distributed in the hope that it will be useful, but
+ * GnuPG is distributed in the hope that it will be useful, but
* WITHOUT ANY WARRANTY; without even the implied warranty of
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
* General Public License for more details.
@@ -28,8 +28,8 @@
* if not, see <http://www.gnu.org/licenses/>.
*/
-#ifndef LIBJNLIB_TYPES_H
-#define LIBJNLIB_TYPES_H
+#ifndef GNUPG_COMMON_TYPES_H
+#define GNUPG_COMMON_TYPES_H
#ifdef HAVE_INTTYPES_H
# include <inttypes.h>
@@ -123,4 +123,4 @@
# define GNUPG_GCC_A_SENTINEL(a)
#endif
-#endif /*LIBJNLIB_TYPES_H*/
+#endif /*GNUPG_COMMON_TYPES_H*/
diff --git a/common/utf8conv.c b/common/utf8conv.c
index bfd00c70d..99cfc2d6d 100644
--- a/common/utf8conv.c
+++ b/common/utf8conv.c
@@ -2,9 +2,9 @@
* Copyright (C) 1994, 1998, 1999, 2000, 2001, 2003, 2006,
* 2008, 2010 Free Software Foundation, Inc.
*
- * This file is part of JNLIB, which is a subsystem of GnuPG.
+ * This file is part of GnuPG.
*
- * JNLIB is free software; you can redistribute it and/or modify it
+ * GnuPG is free software; you can redistribute it and/or modify it
* under the terms of either
*
* - the GNU Lesser General Public License as published by the Free
@@ -19,7 +19,7 @@
*
* or both in parallel, as here.
*
- * JNLIB is distributed in the hope that it will be useful, but
+ * GnuPG is distributed in the hope that it will be useful, but
* WITHOUT ANY WARRANTY; without even the implied warranty of
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
* General Public License for more details.
diff --git a/common/utf8conv.h b/common/utf8conv.h
index a08d3f35d..ad7dbe977 100644
--- a/common/utf8conv.h
+++ b/common/utf8conv.h
@@ -1,9 +1,9 @@
/* utf8conf.h
* Copyright (C) 2003, 2006 Free Software Foundation, Inc.
*
- * This file is part of JNLIB, which is a subsystem of GnuPG.
+ * This file is part of GnuPG.
*
- * JNLIB is free software; you can redistribute it and/or modify it
+ * GnuPG is free software; you can redistribute it and/or modify it
* under the terms of either
*
* - the GNU Lesser General Public License as published by the Free
@@ -18,7 +18,7 @@
*
* or both in parallel, as here.
*
- * JNLIB is distributed in the hope that it will be useful, but
+ * GnuPG is distributed in the hope that it will be useful, but
* WITHOUT ANY WARRANTY; without even the implied warranty of
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
* General Public License for more details.
@@ -28,8 +28,8 @@
* if not, see <http://www.gnu.org/licenses/>.
*/
-#ifndef LIBJNLIB_UTF8CONF_H
-#define LIBJNLIB_UTF8CONF_H
+#ifndef GNUPG_COMMON_UTF8CONF_H
+#define GNUPG_COMMON_UTF8CONF_H
int set_native_charset (const char *newset);
const char *get_native_charset (void);
@@ -53,4 +53,4 @@ wchar_t *utf8_to_wchar (const char *string);
#endif /*HAVE_W32_SYSTEM*/
-#endif /*LIBJNLIB_UTF8CONF_H*/
+#endif /*GNUPG_COMMON_UTF8CONF_H*/
diff --git a/common/util.h b/common/util.h
index 89f8bf28c..0e585df54 100644
--- a/common/util.h
+++ b/common/util.h
@@ -1,9 +1,9 @@
/* util.h - Utility functions for GnuPG
* Copyright (C) 2001, 2002, 2003, 2004, 2009 Free Software Foundation, Inc.
*
- * This file is part of JNLIB, which is a subsystem of GnuPG.
+ * This file is part of GnuPG.
*
- * JNLIB is free software; you can redistribute it and/or modify it
+ * GnuPG is free software; you can redistribute it and/or modify it
* under the terms of either
*
* - the GNU Lesser General Public License as published by the Free
@@ -18,7 +18,7 @@
*
* or both in parallel, as here.
*
- * JNLIB is distributed in the hope that it will be useful, but
+ * GnuPG is distributed in the hope that it will be useful, but
* WITHOUT ANY WARRANTY; without even the implied warranty of
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
* General Public License for more details.
diff --git a/common/w32-afunix.c b/common/w32-afunix.c
index 5f56c29b0..44322196b 100644
--- a/common/w32-afunix.c
+++ b/common/w32-afunix.c
@@ -1,9 +1,9 @@
/* w32-afunix.c - AF_UNIX emulation for Windows (Client only).
* Copyright (C) 2004, 2006 g10 Code GmbH
*
- * This file is part of JNLIB, which is a subsystem of GnuPG.
+ * This file is part of GnuPG.
*
- * JNLIB is free software; you can redistribute it and/or modify it
+ * GnuPG is free software; you can redistribute it and/or modify it
* under the terms of either
*
* - the GNU Lesser General Public License as published by the Free
@@ -18,7 +18,7 @@
*
* or both in parallel, as here.
*
- * JNLIB is distributed in the hope that it will be useful, but
+ * GnuPG is distributed in the hope that it will be useful, but
* WITHOUT ANY WARRANTY; without even the implied warranty of
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
* General Public License for more details.
diff --git a/common/w32-afunix.h b/common/w32-afunix.h
index c9abd7b2b..f6282a3dd 100644
--- a/common/w32-afunix.h
+++ b/common/w32-afunix.h
@@ -1,9 +1,9 @@
/* w32-afunix.h - AF_UNIX emulation for Windows
* Copyright (C) 2004, 2006 g10 Code GmbH
*
- * This file is part of JNLIB, which is a subsystem of GnuPG.
+ * This file is part of GnuPG.
*
- * JNLIB is free software; you can redistribute it and/or modify it
+ * GnuPG is free software; you can redistribute it and/or modify it
* under the terms of either
*
* - the GNU Lesser General Public License as published by the Free
@@ -18,7 +18,7 @@
*
* or both in parallel, as here.
*
- * JNLIB is distributed in the hope that it will be useful, but
+ * GnuPG is distributed in the hope that it will be useful, but
* WITHOUT ANY WARRANTY; without even the implied warranty of
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
* General Public License for more details.
diff --git a/common/w32-reg.c b/common/w32-reg.c
index 6a2b2dd59..6afb599bd 100644
--- a/common/w32-reg.c
+++ b/common/w32-reg.c
@@ -1,9 +1,9 @@
/* w32-reg.c - MS-Windows Registry access
* Copyright (C) 1999, 2002, 2007 Free Software Foundation, Inc.
*
- * This file is part of JNLIB, which is a subsystem of GnuPG.
+ * This file is part of GnuPG.
*
- * JNLIB is free software; you can redistribute it and/or modify it
+ * GnuPG is free software; you can redistribute it and/or modify it
* under the terms of either
*
* - the GNU Lesser General Public License as published by the Free
@@ -18,7 +18,7 @@
*
* or both in parallel, as here.
*
- * JNLIB is distributed in the hope that it will be useful, but
+ * GnuPG is distributed in the hope that it will be useful, but
* WITHOUT ANY WARRANTY; without even the implied warranty of
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
* General Public License for more details.
diff --git a/common/w32help.h b/common/w32help.h
index b9b7c449b..be6dd3e32 100644
--- a/common/w32help.h
+++ b/common/w32help.h
@@ -1,9 +1,9 @@
/* w32help.h - W32 speicif functions
* Copyright (C) 2007 Free Software Foundation, Inc.
*
- * This file is part of JNLIB, which is a subsystem of GnuPG.
+ * This file is part of GnuPG.
*
- * JNLIB is free software; you can redistribute it and/or modify it
+ * GnuPG is free software; you can redistribute it and/or modify it
* under the terms of either
*
* - the GNU Lesser General Public License as published by the Free
@@ -18,7 +18,7 @@
*
* or both in parallel, as here.
*
- * JNLIB is distributed in the hope that it will be useful, but
+ * GnuPG is distributed in the hope that it will be useful, but
* WITHOUT ANY WARRANTY; without even the implied warranty of
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
* General Public License for more details.
@@ -28,8 +28,8 @@
* if not, see <http://www.gnu.org/licenses/>.
*/
-#ifndef LIBJNLIB_W32HELP_H
-#define LIBJNLIB_W32HELP_H
+#ifndef GNUPG_COMMON_W32HELP_H
+#define GNUPG_COMMON_W32HELP_H
#ifdef HAVE_W32_SYSTEM
/*-- w32-reg.c --*/
@@ -53,4 +53,4 @@ umask (int a)
#endif /*HAVE_W32CE_SYSTEM*/
#endif /*HAVE_W32_SYSTEM*/
-#endif /*LIBJNLIB_MISCHELP_H*/
+#endif /*GNUPG_COMMON_MISCHELP_H*/
diff --git a/common/xmalloc.c b/common/xmalloc.c
index 3378e487b..0690a3696 100644
--- a/common/xmalloc.c
+++ b/common/xmalloc.c
@@ -1,9 +1,9 @@
/* xmalloc.c - standard malloc wrappers
* Copyright (C) 1999, 2000, 2001, 2006 Free Software Foundation, Inc.
*
- * This file is part of JNLIB, which is a subsystem of GnuPG.
+ * This file is part of GnuPG.
*
- * JNLIB is free software; you can redistribute it and/or modify it
+ * GnuPG is free software; you can redistribute it and/or modify it
* under the terms of either
*
* - the GNU Lesser General Public License as published by the Free
@@ -18,7 +18,7 @@
*
* or both in parallel, as here.
*
- * JNLIB is distributed in the hope that it will be useful, but
+ * GnuPG is distributed in the hope that it will be useful, but
* WITHOUT ANY WARRANTY; without even the implied warranty of
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
* General Public License for more details.
diff --git a/common/xmalloc.h b/common/xmalloc.h
index 73d6f45bc..d91883d15 100644
--- a/common/xmalloc.h
+++ b/common/xmalloc.h
@@ -1,9 +1,9 @@
/* xmalloc.h
* Copyright (C) 1999, 2000, 2001, 2006 Free Software Foundation, Inc.
*
- * This file is part of JNLIB, which is a subsystem of GnuPG.
+ * This file is part of GnuPG.
*
- * JNLIB is free software; you can redistribute it and/or modify it
+ * GnuPG is free software; you can redistribute it and/or modify it
* under the terms of either
*
* - the GNU Lesser General Public License as published by the Free
@@ -18,7 +18,7 @@
*
* or both in parallel, as here.
*
- * JNLIB is distributed in the hope that it will be useful, but
+ * GnuPG is distributed in the hope that it will be useful, but
* WITHOUT ANY WARRANTY; without even the implied warranty of
* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
* General Public License for more details.
@@ -28,8 +28,8 @@
* if not, see <http://www.gnu.org/licenses/>.
*/
-#ifndef LIBJNLIB_XMALLOC_H
-#define LIBJNLIB_XMALLOC_H
+#ifndef GNUPG_COMMON_XMALLOC_H
+#define GNUPG_COMMON_XMALLOC_H
void *xmalloc( size_t n );
void *xrealloc( void *a, size_t n );
@@ -38,4 +38,4 @@ char *xstrdup( const char *string );
char *xstrcat2( const char *a, const char *b );
-#endif /*LIBJNLIB_XMALLOC_H*/
+#endif /*GNUPG_COMMON_XMALLOC_H*/