aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2005-01-03 15:15:34 +0000
committerDavid Shaw <[email protected]>2005-01-03 15:15:34 +0000
commit14ce45565dfa69bb3a4c7d2c0d809f8e04273fa3 (patch)
tree2a17bd08361230cc22387c232f8a11d12e7d92fe
parent* options.h, import.c (parse_import_options, delete_inv_parts): Add (diff)
downloadgnupg-14ce45565dfa69bb3a4c7d2c0d809f8e04273fa3.tar.gz
gnupg-14ce45565dfa69bb3a4c7d2c0d809f8e04273fa3.zip
* Makefile.am: Use @LIBUSB@ instead of @LIBUSB_LIBS@
* import.c (delete_inv_parts): Comments on import-unusable-sigs.
-rw-r--r--g10/ChangeLog6
-rw-r--r--g10/Makefile.am6
-rw-r--r--g10/import.c6
3 files changed, 15 insertions, 3 deletions
diff --git a/g10/ChangeLog b/g10/ChangeLog
index c999e3ffd..11639c94b 100644
--- a/g10/ChangeLog
+++ b/g10/ChangeLog
@@ -1,3 +1,9 @@
+2005-01-03 David Shaw <[email protected]>
+
+ * Makefile.am: Use @LIBUSB@ instead of @LIBUSB_LIBS@
+
+ * import.c (delete_inv_parts): Comments on import-unusable-sigs.
+
2005-01-01 David Shaw <[email protected]>
* options.h, import.c (parse_import_options, delete_inv_parts):
diff --git a/g10/Makefile.am b/g10/Makefile.am
index 3e7e0e165..1c0551ca9 100644
--- a/g10/Makefile.am
+++ b/g10/Makefile.am
@@ -1,5 +1,5 @@
-# Copyright (C) 1998, 1999, 2000, 2001, 2002,
-# 2003 Free Software Foundation, Inc.
+# Copyright (C) 1998, 1999, 2000, 2001, 2002, 2003,
+# 2004 Free Software Foundation, Inc.
#
# This file is part of GnuPG.
#
@@ -133,7 +133,7 @@ gpgv_SOURCES = gpgv.c \
# $(common_source)
LDADD = $(needed_libs) $(other_libs) @ZLIBS@ @W32LIBS@ @LIBREADLINE@
-gpg_LDADD = $(LDADD) @DLLIBS@ @NETLIBS@ @LIBUSB_LIBS@
+gpg_LDADD = $(LDADD) @DLLIBS@ @NETLIBS@ @LIBUSB@
$(PROGRAMS): $(needed_libs)
diff --git a/g10/import.c b/g10/import.c
index e0d57a508..d0c1c01ac 100644
--- a/g10/import.c
+++ b/g10/import.c
@@ -1565,6 +1565,12 @@ delete_inv_parts( const char *fname, KBNODE keyblock,
|| node->pkt->pkt.signature->keyid[1]!=keyid[1])
&& !(options&IMPORT_UNUSABLE_SIGS))
{
+ /* Note that we haven't necessarily checked this sig for
+ validity. We strip it anyway since if it was valid, it
+ would be expired. If it wasn't valid, it either would
+ be expired if it was valid, or was altered to the point
+ that it looked expired (and so doesn't matter terribly
+ much if it is expired or not). */
if(opt.verbose)
{
char *kid=m_strdup(keystr(keyid));