aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2006-10-20 04:00:19 +0000
committerDavid Shaw <[email protected]>2006-10-20 04:00:19 +0000
commit11935a4c18e20acb58be4fcfd9f99163607c578f (patch)
tree90426a9fde923b2a8b9e0a37a1a94d3497b05d5f
parentFixes (diff)
downloadgnupg-11935a4c18e20acb58be4fcfd9f99163607c578f.tar.gz
gnupg-11935a4c18e20acb58be4fcfd9f99163607c578f.zip
* gpgkeys_hkp.c (curl_mrindex_writer): Print a warning if we see HTML
coming back from a MR hkp query.
-rw-r--r--keyserver/ChangeLog5
-rw-r--r--keyserver/gpgkeys_hkp.c5
2 files changed, 9 insertions, 1 deletions
diff --git a/keyserver/ChangeLog b/keyserver/ChangeLog
index a8f3f8956..a8837f58b 100644
--- a/keyserver/ChangeLog
+++ b/keyserver/ChangeLog
@@ -1,3 +1,8 @@
+2006-10-19 David Shaw <[email protected]>
+
+ * gpgkeys_hkp.c (curl_mrindex_writer): Print a warning if we see
+ HTML coming back from a MR hkp query.
+
2006-10-17 Werner Koch <[email protected]>
* Makefile.am: Removed W32LIBS as they are included in NETLIBS.
diff --git a/keyserver/gpgkeys_hkp.c b/keyserver/gpgkeys_hkp.c
index 1692a5033..4b6dc8157 100644
--- a/keyserver/gpgkeys_hkp.c
+++ b/keyserver/gpgkeys_hkp.c
@@ -68,7 +68,10 @@ curl_mrindex_writer(const void *ptr,size_t size,size_t nmemb,void *stream)
with it on this side of the pipe. */
const char *buf=ptr;
if(buf[0]=='<')
- swallow=1;
+ {
+ fprintf(console,"gpgkeys: unsupported response from keyserver\n");
+ swallow=1;
+ }
checked=1;
}