aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNIIBE Yutaka <[email protected]>2017-04-20 11:43:29 +0000
committerNIIBE Yutaka <[email protected]>2017-04-20 11:43:29 +0000
commit10519270d36586c536bfb6c4cda8ac17c01f4976 (patch)
tree50f184d099967af5a1001cc79ce0bc52917fb237
parentdirmngr: Fix final close of LISTEN_FD. (diff)
downloadgnupg-10519270d36586c536bfb6c4cda8ac17c01f4976.tar.gz
gnupg-10519270d36586c536bfb6c4cda8ac17c01f4976.zip
g13: Fix for Solaris.
* configure.ac: Check sys/mkdev.h. * g13/sh-dmcrypt.c: Include sys/mkdev.h. -- GnuPG-bug-id: 3098 Signed-off-by: NIIBE Yutaka <[email protected]>
-rw-r--r--configure.ac2
-rw-r--r--g13/sh-dmcrypt.c3
2 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4c90d6c48..494e44402 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1278,7 +1278,7 @@ AC_HEADER_STDC
AC_CHECK_HEADERS([string.h unistd.h langinfo.h termio.h locale.h getopt.h \
pty.h utmp.h pwd.h inttypes.h signal.h sys/select.h \
stdint.h signal.h util.h libutil.h termios.h \
- ucred.h sys/sysmacros.h])
+ ucred.h sys/sysmacros.h sys/mkdev.h])
AC_HEADER_TIME
diff --git a/g13/sh-dmcrypt.c b/g13/sh-dmcrypt.c
index c5489c96f..09c4d967b 100644
--- a/g13/sh-dmcrypt.c
+++ b/g13/sh-dmcrypt.c
@@ -25,6 +25,9 @@
#include <errno.h>
#include <assert.h>
#include <sys/types.h>
+#ifdef HAVE_SYS_MKDEV_H
+#include <sys/mkdev.h>
+#endif
#ifdef HAVE_SYS_SYSMACROS_H
# include <sys/sysmacros.h>
#endif