aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2004-02-19 20:10:38 +0000
committerDavid Shaw <[email protected]>2004-02-19 20:10:38 +0000
commit06d21d80f6318beb57cd30be608c1c0a07d3371e (patch)
tree7bd1e0b6f020c009886e495414650bbe08b137fc
parent* Makefile.am: Add automake conditionals to symlink gpgkeys_ldaps to (diff)
downloadgnupg-06d21d80f6318beb57cd30be608c1c0a07d3371e.tar.gz
gnupg-06d21d80f6318beb57cd30be608c1c0a07d3371e.zip
* configure.ac: Check for ln -s and add GPGKEYS_LDAP conditional, both for
making gpgkeys_ldaps symlink to gpgkeys_ldap.
-rw-r--r--ChangeLog3
-rw-r--r--configure.ac2
2 files changed, 5 insertions, 0 deletions
diff --git a/ChangeLog b/ChangeLog
index 5d6dd39b3..64311319a 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,5 +1,8 @@
2004-02-19 David Shaw <[email protected]>
+ * configure.ac: Check for ln -s and add GPGKEYS_LDAP conditional,
+ both for making gpgkeys_ldaps symlink to gpgkeys_ldap.
+
* configure.ac: Simplify the LDAP checking code since OpenLDAP is
far more mature these days and dependencies are cleaner. Add
checks for ldap_set_option and ldap_start_tls_s.
diff --git a/configure.ac b/configure.ac
index 60e4e4651..acf3a9242 100644
--- a/configure.ac
+++ b/configure.ac
@@ -376,6 +376,7 @@ AC_PATH_PROG(PERL,"perl")
AC_ISC_POSIX
AC_SYS_LARGEFILE
AC_PROG_INSTALL
+AC_PROG_LN_S
AC_PROG_AWK
AC_CHECK_PROG(DOCBOOK_TO_MAN, docbook-to-man, yes, no)
AM_CONDITIONAL(HAVE_DOCBOOK_TO_MAN, test "$ac_cv_prog_DOCBOOK_TO_MAN" = yes)
@@ -565,6 +566,7 @@ fi
AC_SUBST(GPGKEYS_LDAP)
AC_SUBST(LDAPLIBS)
+AM_CONDITIONAL(GPGKEYS_LDAP, test "$GPGKEYS_LDAP" != "")
dnl This isn't necessarily sendmail itself, but anything that gives a
dnl sendmail-ish interface to the outside world. That includes qmail,