aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2012-11-16 09:35:33 +0000
committerWerner Koch <[email protected]>2012-11-16 09:41:22 +0000
commit011faa0c68cf0c628ef581193166e9ac9bf22b71 (patch)
tree30732d4e786aa5c4e2c8dc9e726ec51cbda059c5
parentAdd an OpenPGP card vendor. (diff)
downloadgnupg-011faa0c68cf0c628ef581193166e9ac9bf22b71.tar.gz
gnupg-011faa0c68cf0c628ef581193166e9ac9bf22b71.zip
Improve parsing of the GIT revision number.
* configure.ac (mmm4_revision): Use git rev-parse.
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 0241a9d6a..90c77faaa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -31,8 +31,8 @@ m4_define([mym4_version], [2.1.0])
# the decimalized short revision number, a beta version string and a
# flag indicating a development version (mym4_isgit). Note that the
# m4 processing is done by autoconf and not during the configure run.
-m4_define([mym4_revision], m4_esyscmd([git branch -v 2>/dev/null \
- | awk '/^\* / {printf "%s",$3}']))
+m4_define([mym4_revision],
+ m4_esyscmd([git rev-parse --short HEAD | tr -d '\n\r']))
m4_define([mym4_revision_dec],
m4_esyscmd_s([echo $((0x$(echo ]mym4_revision[|head -c 4)))]))
m4_define([mym4_betastring],