aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2017-02-20 08:48:37 +0000
committerWerner Koch <[email protected]>2017-02-20 08:48:37 +0000
commitf923873863fd863d71349f20f5568f80aecc020b (patch)
treeb2bdc708b75e19120604c91756e405b1fb832abc
parentAdjust copyright years for sm/certdump.c (diff)
downloadgnupg-f923873863fd863d71349f20f5568f80aecc020b.tar.gz
gnupg-f923873863fd863d71349f20f5568f80aecc020b.zip
dirmngr: Make t-http.c work again with gnutls.
* dirmngr/Makefile.am (t_http_CFLAGS, t_http_LDADD): Add KSBA flags and libs. Signed-off-by: Werner Koch <[email protected]>
Diffstat (limited to '')
-rw-r--r--dirmngr/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/dirmngr/Makefile.am b/dirmngr/Makefile.am
index 7fa42829d..8d22cc47b 100644
--- a/dirmngr/Makefile.am
+++ b/dirmngr/Makefile.am
@@ -139,12 +139,14 @@ endif
# http tests
+# We need to add the KSBA flags in case we are building against GNUTLS.
+# In that case NTBTLS flags are empty, but we need ksba anyway.
t_http_SOURCES = $(t_common_src) t-http.c http.c dns-stuff.c
t_http_CFLAGS = -DWITHOUT_NPTH=1 $(USE_C99_CFLAGS) \
$(LIBGCRYPT_CFLAGS) $(NTBTLS_CFLAGS) $(LIBGNUTLS_CFLAGS) \
- $(GPG_ERROR_CFLAGS)
+ $(GPG_ERROR_CFLAGS) $(KSBA_CFLAGS)
t_http_LDADD = $(t_common_ldadd) \
- $(NTBTLS_LIBS) $(LIBGNUTLS_LIBS) $(DNSLIBS)
+ $(NTBTLS_LIBS) $(KSBA_LIBS) $(LIBGNUTLS_LIBS) $(DNSLIBS)
t_ldap_parse_uri_SOURCES = \
t-ldap-parse-uri.c ldap-parse-uri.c ldap-parse-uri.h \