aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2004-01-12 03:59:29 +0000
committerDavid Shaw <[email protected]>2004-01-12 03:59:29 +0000
commitf7bcce823f314591396e5e7e6ced1f3342b42d55 (patch)
tree131cdc9b344f3ac546ec413650896a39b6646029
parent* convert-from-106, lspgpot: Check for gpg binary before proceeding. (diff)
downloadgnupg-f7bcce823f314591396e5e7e6ced1f3342b42d55.tar.gz
gnupg-f7bcce823f314591396e5e7e6ced1f3342b42d55.zip
* configure.ac: Include stdio.h when checking for bzlib.h. Solaris 9 has a
very old bzip2 library and we can at least guarantee that it won't fail because of the lack of stdio.h. * THANKS: Added Phong Nguyen, who found the Elgamal signing key problem.
Diffstat (limited to '')
-rw-r--r--ChangeLog9
-rw-r--r--THANKS1
-rw-r--r--configure.ac6
3 files changed, 15 insertions, 1 deletions
diff --git a/ChangeLog b/ChangeLog
index 6a081ccb5..9f901e802 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,12 @@
+2004-01-11 David Shaw <[email protected]>
+
+ * configure.ac: Include stdio.h when checking for bzlib.h. Solaris
+ 9 has a very old bzip2 library and we can at least guarantee that
+ it won't fail because of the lack of stdio.h.
+
+ * THANKS: Added Phong Nguyen, who found the Elgamal signing key
+ problem.
+
2003-11-30 David Shaw <[email protected]>
* NEWS: Note --disable-rsa.
diff --git a/THANKS b/THANKS
index 955781695..2200e8ba2 100644
--- a/THANKS
+++ b/THANKS
@@ -158,6 +158,7 @@ Peter Fales [email protected]
Peter Gutmann [email protected]
Peter Marschall [email protected]
Peter Valchev [email protected]
+Phong Nguyen [email protected]
Piotr Krukowiecki [email protected]
Ralph Gillen [email protected]
diff --git a/configure.ac b/configure.ac
index 6d9449164..fb096a695 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1042,6 +1042,10 @@ if test "$use_bzip2" = yes ; then
fi
],withval="")
+# Checking alongside stdio.h as an early version of bzip2 (1.0)
+# required stdio.h to be included before bzlib.h, and Solaris 9 is
+# woefully out of date.
+
if test "$withval" != no ; then
AC_CHECK_HEADER(bzlib.h,
AC_CHECK_LIB(bz2,BZ2_bzCompressInit,
@@ -1052,7 +1056,7 @@ if test "$use_bzip2" = yes ; then
[Defined if the bz2 compression library is available])
],
CPPFLAGS=${_cppflags} LDFLAGS=${_ldflags}),
- CPPFLAGS=${_cppflags} LDFLAGS=${_ldflags})
+ CPPFLAGS=${_cppflags} LDFLAGS=${_ldflags},[#include <stdio.h>])
fi
fi