aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2014-06-03 11:34:24 +0000
committerWerner Koch <[email protected]>2014-06-25 07:45:56 +0000
commitf149e05427a370f5985bc3fb142370b043f19924 (patch)
tree7db209cedd46fc0d89d08fce22df15d0c61fec64
parentgpg: Allow key-to-card upload for cert-only keys (diff)
downloadgnupg-f149e05427a370f5985bc3fb142370b043f19924.tar.gz
gnupg-f149e05427a370f5985bc3fb142370b043f19924.zip
doc: Update for modern makeinfo.
* doc/texi.css: Remove. * doc/Makefile.am (AM_MAKEINFOFLAGS): Use --css-ref.
Diffstat (limited to '')
-rw-r--r--doc/Makefile.am18
-rw-r--r--doc/gpg.texi13
2 files changed, 18 insertions, 13 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 4d6d47572..43d69cd21 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -34,7 +34,7 @@ EXTRA_DIST = samplekeys.asc mksamplekeys \
gnupg-card-architecture.pdf \
FAQ gnupg7.texi \
opt-homedir.texi see-also-note.texi specify-user-id.texi \
- gpgv.texi texi.css yat2m.c ChangeLog-2011
+ gpgv.texi yat2m.c ChangeLog-2011
BUILT_SOURCES = gnupg-card-architecture.eps gnupg-card-architecture.png \
gnupg-card-architecture.pdf
@@ -57,7 +57,7 @@ gnupg_TEXINFOS = \
DVIPS = TEXINPUTS="$(srcdir)$(PATH_SEPARATOR)$$TEXINPUTS" dvips
-AM_MAKEINFOFLAGS = -I $(srcdir) --css-include=$(srcdir)/texi.css -D gpgtwoone
+AM_MAKEINFOFLAGS = -I $(srcdir) --css-ref=/share/site.css -D gpgtwoone
YAT2M_OPTIONS = -I $(srcdir) -D gpgtwoone \
--release "GnuPG @PACKAGE_VERSION@" --source "GNU Privacy Guard"
@@ -130,15 +130,15 @@ online: gnupg.html gnupg.pdf
set -e; \
echo "Uploading current manuals to www.gnupg.org ..."; \
cp $(srcdir)/gnupg-logo-tr.png gnupg.html/; \
- user=werner ; dashdevel="" ; \
+ user=werner ; webhost="ftp.gnupg.org" ; dashdevel="" ; \
if echo "@PACKAGE_VERSION@" | grep -- "-git" >/dev/null; then \
dashdevel="-devel" ; \
else \
- rsync -v gnupg.pdf $${user}@cvs.gnupg.org:webspace/manuals/ ; \
+ rsync -v gnupg.pdf $${user}@$${webhost}:webspace/manuals/ ; \
fi ; \
cd gnupg.html ; \
- rsync -vr --exclude='.svn' . \
- $${user}@cvs.gnupg.org:webspace/manuals/gnupg$${dashdevel}/
+ rsync -vr --exclude='.git' . \
+ $${user}@$${webhost}:webspace/manuals/gnupg$${dashdevel}/
# Note that you need a recent version of emacs23 with org-mode 7.01h
faq.txt faq.html: faq.org
@@ -155,8 +155,8 @@ faq.txt faq.html: faq.org
faq-online: faq.txt faq.html
set -e; \
- user=werner ; \
+ user=werner ; webhost="ftp.gnupg.org" ; ftphost="ftp.gnupg.org" ; \
echo "Uploading current FAQ to {www,ftp}.gnupg.org ..."; \
- scp faq.html $${user}@ftp.gnupg.org:webspace/manuals/GnuPG-FAQ.html ; \
- scp faq.txt $${user}@ftp.gnupg.org:gcrypt/gnupg/GnuPG-FAQ.txt ; \
+ scp faq.html $${user}@$${webhost}:webspace/manuals/GnuPG-FAQ.html ; \
+ scp faq.txt $${user}@$${ftphost}:gcrypt/gnupg/GnuPG-FAQ.txt ; \
echo "...ready"
diff --git a/doc/gpg.texi b/doc/gpg.texi
index 9a6782a43..9c52282cb 100644
--- a/doc/gpg.texi
+++ b/doc/gpg.texi
@@ -2330,12 +2330,17 @@ a message that PGP 2.x will not be able to handle. Note that `PGP
2.x' here means `MIT PGP 2.6.2'. There are other versions of PGP 2.x
available, but the MIT release is a good common baseline.
-This option implies @option{--rfc1991 --disable-mdc
---no-force-v4-certs --escape-from-lines --force-v3-sigs
+This option implies
+@ifset gpgone
+@option{--rfc1991 --disable-mdc --no-force-v4-certs
+ --escape-from-lines --force-v3-sigs
+ --cipher-algo IDEA --digest-algo MD5 --compress-algo ZIP}.
+@end ifset
@ifclear gpgone
---allow-weak-digest-algos
+@option{--rfc1991 --disable-mdc --no-force-v4-certs
+ --escape-from-lines --force-v3-sigs --allow-weak-digest-algos
+ --cipher-algo IDEA --digest-algo MD5 --compress-algo ZIP}.
@end ifclear
---cipher-algo IDEA --digest-algo MD5 --compress-algo ZIP}.
It also disables @option{--textmode} when encrypting.
@item --pgp6