aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2003-11-14 11:36:04 +0000
committerWerner Koch <[email protected]>2003-11-14 11:36:04 +0000
commitecba8bf1f5268f7a3b44e45c5648ff73e3e3c8da (patch)
treee4ee4b4bdd9de0aaeac68cc3ce1d53ec623c08bb
parent(vasprintf): Also fixed the prototype. (diff)
downloadgnupg-ecba8bf1f5268f7a3b44e45c5648ff73e3e3c8da.tar.gz
gnupg-ecba8bf1f5268f7a3b44e45c5648ff73e3e3c8da.zip
Removed.
Diffstat (limited to '')
-rw-r--r--common/ChangeLog4
-rw-r--r--common/Makefile.am1
-rw-r--r--common/cryptmiss.c39
3 files changed, 4 insertions, 40 deletions
diff --git a/common/ChangeLog b/common/ChangeLog
index afc48367c..da80507f2 100644
--- a/common/ChangeLog
+++ b/common/ChangeLog
@@ -1,3 +1,7 @@
+2003-11-14 Werner Koch <[email protected]>
+
+ * cryptmiss.c: Removed.
+
2003-11-13 Werner Koch <[email protected]>
* util.h (vasprintf): Also fixed the prototype.
diff --git a/common/Makefile.am b/common/Makefile.am
index 3fd1c9454..79dedca34 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -31,7 +31,6 @@ libcommon_a_SOURCES = \
errors.h \
maperror.c \
sysutils.c sysutils.h \
- cryptmiss.c \
gettime.c \
yesno.c \
miscellaneous.c \
diff --git a/common/cryptmiss.c b/common/cryptmiss.c
deleted file mode 100644
index ae639db1d..000000000
--- a/common/cryptmiss.c
+++ /dev/null
@@ -1,39 +0,0 @@
-/* cryptmiss.c - Missing functions in libgcrypt
- * Copyright (C) 2002 Free Software Foundation, Inc.
- *
- * This file is part of GnuPG.
- *
- * GnuPG is free software; you can redistribute it and/or modify
- * it under the terms of the GNU General Public License as published by
- * the Free Software Foundation; either version 2 of the License, or
- * (at your option) any later version.
- *
- * GnuPG is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- * GNU General Public License for more details.
- *
- * You should have received a copy of the GNU General Public License
- * along with this program; if not, write to the Free Software
- * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
- */
-
-#include <config.h>
-#include <errno.h>
-#include <stdio.h>
-#include <stdlib.h>
-#include <string.h>
-#include <ctype.h>
-
-#include "util.h"
-
-char *
-gcry_strdup (const char *string)
-{
- char *p;
-
- p = gcry_malloc (strlen (string)+1);
- if (p)
- strcpy (p, string);
- return p;
-}