aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2003-05-26 14:14:03 +0000
committerDavid Shaw <[email protected]>2003-05-26 14:14:03 +0000
commitd61c869d7502cdec5c4354eae0c3c39ddf69c848 (patch)
treeb518b1847c8e8b516054f8d3c9c2b9efc7d2b7c4
parent* mk-w32-dist: Don't iconv {hu,sk,zh_TW}.po. (From wk on stable branch) (diff)
downloadgnupg-d61c869d7502cdec5c4354eae0c3c39ddf69c848.tar.gz
gnupg-d61c869d7502cdec5c4354eae0c3c39ddf69c848.zip
* defs.inc (pgmname): Make sure there is a valid options file. (From wk on
stable branch) * mds.test: Note that missing algorithms are not errors.
Diffstat (limited to '')
-rw-r--r--checks/ChangeLog7
-rwxr-xr-xchecks/defs.inc11
-rwxr-xr-xchecks/mds.test6
3 files changed, 20 insertions, 4 deletions
diff --git a/checks/ChangeLog b/checks/ChangeLog
index 999ff42a0..55aa0481a 100644
--- a/checks/ChangeLog
+++ b/checks/ChangeLog
@@ -1,3 +1,10 @@
+2003-05-26 David Shaw <[email protected]>
+
+ * defs.inc (pgmname): Make sure there is a valid options
+ file. (From wk on stable branch)
+
+ * mds.test: Note that missing algorithms are not errors.
+
2003-04-23 David Shaw <[email protected]>
* Makefile.am, options.in: Rename options.in to options since it
diff --git a/checks/defs.inc b/checks/defs.inc
index 2eb25c7f1..778f539a1 100755
--- a/checks/defs.inc
+++ b/checks/defs.inc
@@ -98,9 +98,18 @@ pgmname=`basename $0`
[ -z "$srcdir" ] && fatal "not called from make"
+# Make sure we have a valid option files even with VPATH builds.
+if [ -f ./options ]; then
+ :
+elif [ -f ./gpg.conf ]; then
+ :
+elif [ -f $srcdir/options ]; then
+ cat $srcdir/options >gpg.conf
+fi
+
GPG="../g10/gpg --homedir . "
exec 2> ${pgmname}.log
:
-# end \ No newline at end of file
+# end
diff --git a/checks/mds.test b/checks/mds.test
index 5a554bfcf..eb36193a4 100755
--- a/checks/mds.test
+++ b/checks/mds.test
@@ -24,7 +24,7 @@ test_one ":3:" "9C1185A5C5E9FC54612808977EE8F548B2258D31"
if have_hash_algo "TIGER192"; then
test_one ":6:" "24F0130C63AC933216166E76B1BB925FF373DE2D49584E7A"
else
- echo "Hash algorithm TIGER/192 is not installed"
+ echo "Hash algorithm TIGER/192 is not installed (not an error)"
fi
# SHA-256
test_one ":8:" "E3B0C44298FC1C149AFBF4C8996FB92427AE41E4649B934CA495991B7852B855"
@@ -32,13 +32,13 @@ test_one ":8:" "E3B0C44298FC1C149AFBF4C8996FB92427AE41E4649B934CA495991B7852B
if have_hash_algo "SHA384"; then
test_one ":9:" "38B060A751AC96384CD9327EB1B1E36A21FDB71114BE07434C0CC7BF63F6E1DA274EDEBFE76F65FBD51AD2F14898B95B"
else
- echo "Hash algorithm SHA-384 is not installed"
+ echo "Hash algorithm SHA-384 is not installed (not an error)"
fi
# SHA-512
if have_hash_algo "SHA512"; then
test_one ":10:" "CF83E1357EEFB8BDF1542850D66D8007D620E4050B5715DC83F4A921D36CE9CE47D0D13C5D85F2B0FF8318D2877EEC2F63B931BD47417A81A538327AF927DA3E"
else
- echo "Hash algorithm SHA-512 is not installed"
+ echo "Hash algorithm SHA-512 is not installed (not an error)"
fi
[ "$failed" != "" ] && error "$failed failed for empty string"