aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2003-02-23 05:08:26 +0000
committerDavid Shaw <[email protected]>2003-02-23 05:08:26 +0000
commitc65d9f48834602c86adfae988a00d23d90b562f8 (patch)
tree4862324e45b72d698c6092d988344bd42f0745d6
parent* sign.c (sign_file): Do not push textmode filter onto an unopened IOBUF (diff)
downloadgnupg-c65d9f48834602c86adfae988a00d23d90b562f8.tar.gz
gnupg-c65d9f48834602c86adfae988a00d23d90b562f8.zip
* convert-from-106: Move to the tools directory.
Diffstat (limited to '')
-rw-r--r--scripts/ChangeLog4
-rwxr-xr-xscripts/convert-from-10652
2 files changed, 4 insertions, 52 deletions
diff --git a/scripts/ChangeLog b/scripts/ChangeLog
index 51b030057..df1b804a4 100644
--- a/scripts/ChangeLog
+++ b/scripts/ChangeLog
@@ -1,3 +1,7 @@
+2003-02-22 David Shaw <[email protected]>
+
+ * convert-from-106: Move to the tools directory.
+
2002-12-01 David Shaw <[email protected]>
* distfiles, gnupg.spec.in: Include convert-from-106.
diff --git a/scripts/convert-from-106 b/scripts/convert-from-106
deleted file mode 100755
index b8225d28e..000000000
--- a/scripts/convert-from-106
+++ /dev/null
@@ -1,52 +0,0 @@
-#!/bin/sh
-# Copyright (C) 2002 Free Software Foundation, Inc.
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
-
-gpg="../g10/gpg --no-greeting --no-secmem-warning";
-
-echo "This script converts your public keyring and trustdb from GnuPG"
-echo "1.0.6 or earlier to the 1.0.7 and later format."
-
-echo "If you have already done this, there is no harm (but no point)"
-echo "in doing it again."
-
-echo -n "Continue? (y/N)"
-
-read answer
-
-if test "x$answer" != "xy" ; then
- exit 0
-fi
-
-echo
-echo "Marking your keys as ultimately trusted"
-for key in `$gpg --with-colons --list-secret-keys | grep sec: | cut -d: -f5`
-do
- $gpg --trusted-key $key --with-colons --list-keys $key > /dev/null 2>&1
- echo -n "."
-done
-echo
-
-echo
-echo "Adding signature caches"
-$gpg --rebuild-keydb-caches
-
-echo
-echo "Checking trustdb"
-$gpg --check-trustdb
-
-echo
-echo "Done!"