aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2005-12-06 17:13:44 +0000
committerDavid Shaw <[email protected]>2005-12-06 17:13:44 +0000
commitc0d7fa368ecbb559c5d4e7c9f002718bd2539270 (patch)
tree441be8628db6cb72a6bcf3ac55a38830415381ee
parent* main.h, keylist.c (print_revokers): New. Print the "rvk" designated (diff)
downloadgnupg-c0d7fa368ecbb559c5d4e7c9f002718bd2539270.tar.gz
gnupg-c0d7fa368ecbb559c5d4e7c9f002718bd2539270.zip
* Makefile.am: Some cleanup so we don't build files that are completely
ifdeffed out. This causes a warning on Sun's cc. Do sha512.c as well for consistency.
Diffstat (limited to '')
-rw-r--r--ChangeLog6
-rw-r--r--cipher/ChangeLog6
-rw-r--r--cipher/Makefile.am32
-rw-r--r--configure.ac24
4 files changed, 54 insertions, 14 deletions
diff --git a/ChangeLog b/ChangeLog
index db90a1ca7..96e16ac15 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,9 @@
+2005-12-06 David Shaw <[email protected]>
+
+ * configure.ac: Some cleanup so we don't build files that are
+ completely ifdeffed out. This causes a warning on Sun's cc. Do
+ sha512.c as well for consistency.
+
2005-11-17 David Shaw <[email protected]>
* NEWS: Note backsigs, the xxxxx-clean options, and the
diff --git a/cipher/ChangeLog b/cipher/ChangeLog
index f0e7efb0f..1efddea8f 100644
--- a/cipher/ChangeLog
+++ b/cipher/ChangeLog
@@ -1,3 +1,9 @@
+2005-12-06 David Shaw <[email protected]>
+
+ * Makefile.am: Some cleanup so we don't build files that are
+ completely ifdeffed out. This causes a warning on Sun's cc. Do
+ sha512.c as well for consistency.
+
2005-08-11 Werner Koch <[email protected]>
* rijndael.c (rijndael_cfb_encrypt): Experimental code to improve
diff --git a/cipher/Makefile.am b/cipher/Makefile.am
index 12c4bb0b5..0aef60579 100644
--- a/cipher/Makefile.am
+++ b/cipher/Makefile.am
@@ -1,4 +1,5 @@
-# Copyright (C) 1998, 1999, 2000, 2001, 2002 Free Software Foundation, Inc.
+# Copyright (C) 1998, 1999, 2000, 2001, 2002, 2003,
+# 2005 Free Software Foundation, Inc.
#
# This file is part of GnuPG.
#
@@ -44,16 +45,31 @@ libcipher_a_SOURCES = cipher.c \
dsa.c \
smallprime.c \
algorithms.h \
- rndlinux.c \
- rndunix.c \
- rndegd.c \
- rndw32.c \
md5.c \
rmd160.c \
sha1.c \
sha256.c
-EXTRA_libcipher_a_SOURCES = idea-stub.c sha512.c
+if USE_RNDLINUX
+libcipher_a_SOURCES+=rndlinux.c
+endif
-libcipher_a_DEPENDENCIES = @IDEA_O@ @SHA512_O@
-libcipher_a_LIBADD = @IDEA_O@ @SHA512_O@
+if USE_RNDUNIX
+libcipher_a_SOURCES+=rndunix.c
+endif
+
+if USE_RNDEGD
+libcipher_a_SOURCES+=rndegd.c
+endif
+
+if USE_RNDW32
+libcipher_a_SOURCES+=rndw32.c
+endif
+
+if USE_SHA512
+libcipher_a_SOURCES+=sha512.c
+endif
+
+EXTRA_libcipher_a_SOURCES=idea-stub.c
+libcipher_a_DEPENDENCIES=@IDEA_O@
+libcipher_a_LIBADD=@IDEA_O@
diff --git a/configure.ac b/configure.ac
index 761132bb2..076e29b6b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -800,18 +800,21 @@ if test "$ac_cv_sizeof_unsigned_short" = "0" \
fi
dnl Do we have any 64-bit data types?
-if test "$ac_cv_sizeof_unsigned_int" != "8" \
+if test x"$use_sha512" = xyes \
+ && test "$ac_cv_sizeof_unsigned_int" != "8" \
&& test "$ac_cv_sizeof_unsigned_long" != "8" \
&& test "$ac_cv_sizeof_unsigned_long_long" != "8" \
&& test x"$ac_cv_sizeof_uint64_t" != "x8"; then
AC_MSG_NOTICE([No 64-bit types. Disabling SHA-384 and SHA-512.])
-else
- if test x"$use_sha512" = xyes ; then
- AC_SUBST(SHA512_O,sha512.o)
- AC_DEFINE(USE_SHA512,1,[Define to include the SHA-384 and SHA-512 digests])
- fi
+ use_sha512=no
+fi
+
+if test x"$use_sha512" ; then
+ AC_DEFINE(USE_SHA512,1,[Define to include the SHA-384 and SHA-512 digests])
fi
+AM_CONDITIONAL(USE_SHA512, test x"$use_sha512" = xyes)
+
dnl Checks for library functions.
AC_CHECK_DECLS(getpagesize)
AC_FUNC_FSEEKO
@@ -978,23 +981,32 @@ for rndmod in $random_modules "" ; do
rndlinux)
AC_DEFINE(USE_RNDLINUX,1,
[Defined if the /dev/random based RNG should be used.])
+ use_rndlinux=yes
;;
rndunix)
AC_DEFINE(USE_RNDUNIX,1,
[Defined if the default Unix RNG should be used.])
print_egd_warning=yes
+ use_rndunix=yes
;;
rndegd)
AC_DEFINE(USE_RNDEGD,1,
[Defined if the EGD based RNG should be used.])
+ use_rndegd=yes
;;
rndw32)
AC_DEFINE(USE_RNDW32,1,
[Defined if the Windows specific RNG should be used.])
+ use_rndw32=yes
;;
esac
done
+AM_CONDITIONAL(USE_RNDLINUX, test "$use_rndlinux" = yes)
+AM_CONDITIONAL(USE_RNDUNIX, test "$use_rndunix" = yes)
+AM_CONDITIONAL(USE_RNDEGD, test "$use_rndegd" = yes)
+AM_CONDITIONAL(USE_RNDW32, test "$use_rndw32" = yes)
+
dnl setup assembler stuff
AC_MSG_CHECKING(for mpi assembler functions)
if test -f $srcdir/mpi/config.links ; then