aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustus Winter <[email protected]>2016-11-29 13:25:19 +0000
committerJustus Winter <[email protected]>2016-11-29 13:45:56 +0000
commitbde4fddadc75ad6071e3fc6c0980905de14c03cb (patch)
tree13f057531e46345dcfa0f125e392c0945d9681ab
parentgpgscm: Avoid truncating pointers. (diff)
downloadgnupg-bde4fddadc75ad6071e3fc6c0980905de14c03cb.tar.gz
gnupg-bde4fddadc75ad6071e3fc6c0980905de14c03cb.zip
tests: Add test for '--decrypt --multifile'.
* tests/openpgp/Makefile.am (XTESTS): Add new test. * tests/openpgp/decrypt-multifile.scm: New file. Signed-off-by: Justus Winter <[email protected]>
Diffstat (limited to '')
-rw-r--r--tests/openpgp/Makefile.am1
-rwxr-xr-xtests/openpgp/decrypt-multifile.scm47
2 files changed, 48 insertions, 0 deletions
diff --git a/tests/openpgp/Makefile.am b/tests/openpgp/Makefile.am
index 3cdf3d1ca..9eb69ee41 100644
--- a/tests/openpgp/Makefile.am
+++ b/tests/openpgp/Makefile.am
@@ -47,6 +47,7 @@ XTESTS = \
version.scm \
mds.scm \
decrypt.scm \
+ decrypt-multifile.scm \
decrypt-dsa.scm \
sigs.scm \
sigs-dsa.scm \
diff --git a/tests/openpgp/decrypt-multifile.scm b/tests/openpgp/decrypt-multifile.scm
new file mode 100755
index 000000000..4efdf6631
--- /dev/null
+++ b/tests/openpgp/decrypt-multifile.scm
@@ -0,0 +1,47 @@
+#!/usr/bin/env gpgscm
+
+;; Copyright (C) 2016 g10 Code GmbH
+;;
+;; This file is part of GnuPG.
+;;
+;; GnuPG is free software; you can redistribute it and/or modify
+;; it under the terms of the GNU General Public License as published by
+;; the Free Software Foundation; either version 3 of the License, or
+;; (at your option) any later version.
+;;
+;; GnuPG is distributed in the hope that it will be useful,
+;; but WITHOUT ANY WARRANTY; without even the implied warranty of
+;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;; GNU General Public License for more details.
+;;
+;; You should have received a copy of the GNU General Public License
+;; along with this program; if not, see <http://www.gnu.org/licenses/>.
+
+(load (with-path "defs.scm"))
+(setup-legacy-environment)
+
+(info "Checking decryption of supplied files using --multifile.")
+
+(define my-wd (getcwd))
+(define encrypted-files (map (lambda (name)
+ (string-append name ".asc"))
+ plain-files))
+
+(with-temporary-working-directory
+ ;; First, copy the files so that GnuPG writes the decrypted files here
+ ;; and not into the source directory.
+ (for-each (lambda (name)
+ (file-copy (in-srcdir name) name))
+ encrypted-files)
+
+ ;; Now decrypt all files.
+ (call-check `(,@gpg --decrypt --multifile ,@encrypted-files))
+
+ ;; And verify the result. Reference files are in our original
+ ;; working directory courtesy of setup-legacy-environment.
+ (for-each-p
+ "Verifying files:"
+ (lambda (name)
+ (unless (file=? (path-join my-wd name) name)
+ (error "decrypted file differs")))
+ plain-files))