aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2006-04-12 10:36:23 +0000
committerWerner Koch <[email protected]>2006-04-12 10:36:23 +0000
commitb2f4b15b7c92c6b16a2e69e6be954971fdfe8d80 (patch)
treeec1bbb4d2871524a4b5001b49dc0264d97356052
parent* memory.c (realloc): Revert m_guard fix and stick an #error in there to (diff)
downloadgnupg-b2f4b15b7c92c6b16a2e69e6be954971fdfe8d80.tar.gz
gnupg-b2f4b15b7c92c6b16a2e69e6be954971fdfe8d80.zip
use minimal posix sed
Diffstat (limited to '')
-rw-r--r--ChangeLog5
-rw-r--r--configure.ac3
-rw-r--r--doc/ChangeLog4
-rw-r--r--doc/gpg.sgml16
4 files changed, 20 insertions, 8 deletions
diff --git a/ChangeLog b/ChangeLog
index 6ddb94b10..4d5266072 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,8 @@
+2006-04-12 Werner Koch <[email protected]>
+
+ * configure.ac: Print version at end of run.
+ (svn_revision): Posix adjustment.
+
2006-04-07 Werner Koch <[email protected]>
* configure.ac: Use new method to include the SVN revison. Now it
diff --git a/configure.ac b/configure.ac
index d2380708f..a7d7bb934 100644
--- a/configure.ac
+++ b/configure.ac
@@ -31,7 +31,7 @@ m4_define([my_version], [1.4.4])
m4_define([my_issvn], [yes])
m4_define([svn_revision], m4_esyscmd([echo -n $((svn info 2>/dev/null \
- || echo 'Revision: 0')|sed -n '/^Revision:/ {s/[^0-9]//gp;q}')]))
+ || echo 'Revision: 0')|sed -n '/^Revision:/ s/[^0-9]//gp'|head -1)]))
AC_INIT([gnupg], my_version[]m4_if(my_issvn,[yes],[-svn[]svn_revision]),
# Set development_version to yes if the minor number is odd or you
@@ -1407,6 +1407,7 @@ AC_OUTPUT
# Give some feedback
echo
+echo " Version info: $PACKAGE_STRING"
echo " Configured for: $PRINTABLE_OS_NAME ($host)"
if test -n "$show_extraasm"; then
echo " Extra cpu specific functions:$show_extraasm"
diff --git a/doc/ChangeLog b/doc/ChangeLog
index a70ddbba5..c0a640e8d 100644
--- a/doc/ChangeLog
+++ b/doc/ChangeLog
@@ -1,3 +1,7 @@
+2006-04-11 Michael Roth <[email protected]> (wk)
+
+ * gpg.sgml (passphrase-fd): Explain that only the first line is used.
+
2006-04-09 David Shaw <[email protected]>
* gpg.sgml: Some typo fixes. This is Debian 361324.
diff --git a/doc/gpg.sgml b/doc/gpg.sgml
index aa90c43d7..297f6c940 100644
--- a/doc/gpg.sgml
+++ b/doc/gpg.sgml
@@ -2340,18 +2340,20 @@ Enabled by default. --no-escape-from-lines disables this option.
<varlistentry>
<term>--passphrase-fd &ParmN;</term>
<listitem><para>
-Read the passphrase from file descriptor &ParmN;. If you use 0 for
-&ParmN;, the passphrase will be read from stdin. This can only be
-used if only one passphrase is supplied.
+Read the passphrase from file descriptor &ParmN;. Only the first line
+will be read from file descriptor &ParmN;. If you use 0 for &ParmN;,
+the passphrase will be read from stdin. This can only be used if only
+one passphrase is supplied.
</para></listitem></varlistentry>
<varlistentry>
<term>--passphrase-file &ParmFile;</term>
<listitem><para>
-Read the passphrase from file &ParmFile;. This can only be used if
-only one passphrase is supplied. Obviously, a passphrase stored in a
-file is of questionable security if other users can read this file.
-Don't use this option if you can avoid it.
+Read the passphrase from file &ParmFile;. Only the first line will
+be read from file &ParmFile;. This can only be used if only one
+passphrase is supplied. Obviously, a passphrase stored in a file is
+of questionable security if other users can read this file. Don't use
+this option if you can avoid it.
</para></listitem></varlistentry>
<varlistentry>