diff options
author | David Shaw <[email protected]> | 2005-01-19 03:56:25 +0000 |
---|---|---|
committer | David Shaw <[email protected]> | 2005-01-19 03:56:25 +0000 |
commit | b2d67e803997166b057fd3bd43aa4a93c93409cd (patch) | |
tree | 458c76c317b6089d1f5fa942f62069ce01724b83 | |
parent | * gpgkeys_curl.c: Fix typo. (diff) | |
download | gnupg-b2d67e803997166b057fd3bd43aa4a93c93409cd.tar.gz gnupg-b2d67e803997166b057fd3bd43aa4a93c93409cd.zip |
* NEWS: Note --rfc2440-text import/export-unusable-sigs and
gpgkeys_curl.
* configure.ac: gpgkeys_mailto is disabled by default. Define HTTPS
flag if we're using curl, and HTTPS is available.
Diffstat (limited to '')
-rw-r--r-- | ChangeLog | 8 | ||||
-rw-r--r-- | NEWS | 17 | ||||
-rw-r--r-- | configure.ac | 9 |
3 files changed, 31 insertions, 3 deletions
@@ -1,3 +1,11 @@ +2005-01-18 David Shaw <[email protected]> + + * NEWS: Note --rfc2440-text import/export-unusable-sigs and + gpgkeys_curl. + + * configure.ac: gpgkeys_mailto is disabled by default. Define + HTTPS flag if we're using curl, and HTTPS is available. + 2005-01-17 Werner Koch <[email protected]> * configure.ac: Make --without-included-zlib work as @@ -1,6 +1,23 @@ Noteworthy changes in version 1.4.1 ------------------------------------------------- + * New --rfc2440-text option which controls how text is handled in + signatures. This is in response to some problems seen with + certain PGP/MIME mail clients and GnuPG version 1.4.0. More + details about this are available at + <http://lists.gnupg.org/pipermail/gnupg-users/2005-January/024408.html> + + * New "import-unusable-sigs" and "export-unusable-sigs" tags for + --import-options and --export-options. These are on by + default, and cause GnuPG to not import or export key signatures + that are not usable (e.g. expired signatures). + + * New experimental HTTP, HTTPS, and FTP keyserver helper that uses + the cURL library (http://curl.haxx.se) to retrieve keys. This + is disabled by default, but may be enabled with the configure + option --with-libcurl. Without this option, the existing HTTP + code is used for HTTP, and HTTPS and FTP are not supported. + Noteworthy changes in version 1.4.0 (2004-12-16) ------------------------------------------------- diff --git a/configure.ac b/configure.ac index 4b7056c91..d9f15bd00 100644 --- a/configure.ac +++ b/configure.ac @@ -332,9 +332,9 @@ dnl LDAP is defined only after we confirm the library is available later AC_MSG_CHECKING([whether email keyserver support is requested]) AC_ARG_ENABLE(mailto, - AC_HELP_STRING([--disable-mailto], - [disable email keyserver interface only]), - try_mailto=$enableval, try_mailto=yes) + AC_HELP_STRING([--enable-mailto], + [enable email keyserver interface only]), + try_mailto=$enableval, try_mailto=no) AC_MSG_RESULT($try_mailto) fi @@ -656,6 +656,9 @@ if test x"$try_http" = xyes ; then if test x$libcurl_protocol_HTTP = xyes ; then AC_SUBST(GPGKEYS_CURL,"gpgkeys_curl$EXEEXT") AC_DEFINE(HTTP_VIA_LIBCURL,1,[Define if HTTP is handled via libcurl]) + if test x$libcurl_protocol_HTTPS = xyes ; then + AC_DEFINE(HTTPS_VIA_LIBCURL,1,[Define if HTTPS is handled via libcurl]) + fi else AC_SUBST(GPGKEYS_HTTP,"gpgkeys_http$EXEEXT") fi |