aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2003-10-16 23:44:03 +0000
committerDavid Shaw <[email protected]>2003-10-16 23:44:03 +0000
commitb194ed0e0a0f04d4e5358030ce5d5e7bed1b7f00 (patch)
treebb81e54d85cab9d9dd087f3a652a6bf7c7f26e3b
parent* import.c (import_one): Show the keyid when giving the Elgamal slow (diff)
downloadgnupg-b194ed0e0a0f04d4e5358030ce5d5e7bed1b7f00.tar.gz
gnupg-b194ed0e0a0f04d4e5358030ce5d5e7bed1b7f00.zip
* configure.ac: Include -ldl when card support is used.
Diffstat (limited to '')
-rw-r--r--ChangeLog4
-rw-r--r--configure.ac37
2 files changed, 28 insertions, 13 deletions
diff --git a/ChangeLog b/ChangeLog
index f20228d90..ad3acafc2 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,7 @@
+2003-10-16 David Shaw <[email protected]>
+
+ * configure.ac: Include -ldl when card support is used.
+
2003-10-10 Werner Koch <[email protected]>
Release 1.3.3.
diff --git a/configure.ac b/configure.ac
index fa8000927..5d24d1529 100644
--- a/configure.ac
+++ b/configure.ac
@@ -108,16 +108,11 @@ AC_ARG_ENABLE(card-support,
[ --enable-card-support enable OpenPGP card support],
card_support=$enableval, card_support=no)
AC_MSG_RESULT($card_support)
-if test "$card_support" = yes ; then
- AC_DEFINE(ENABLE_CARD_SUPPORT,1,
- [Define to include the OpenPGP card support])
-fi
-AM_CONDITIONAL(ENABLE_CARD_SUPPORT, test "$card_support" = yes)
dnl See if we are disabling any algorithms or features for a smaller
dnl binary
-try_dynload=no
+try_extensions=no
use_idea=yes
use_cast5=yes
@@ -160,7 +155,7 @@ if test x"$use_idea" = xyes ; then
else
IDEA_O=idea-stub.o
tmp=no
- try_dynload=yes
+ try_extensions=yes
fi
AC_SUBST(IDEA_O)
AC_MSG_RESULT($tmp)
@@ -584,7 +579,7 @@ case "${target}" in
;;
i?86-*-msdosdjgpp*)
PRINTABLE_OS_NAME="MSDOS/DJGPP"
- try_dynload=no
+ try_extensions=no
;;
*-linux*)
PRINTABLE_OS_NAME="GNU/Linux"
@@ -638,19 +633,35 @@ else
AC_SUBST(BUILD_INCLUDED_LIBINTL)
fi
-if test "$try_dynload" = yes ; then
+if test "$try_extensions" = yes || test x"$card_support" = xyes ; then
AC_CHECK_FUNC(dlopen,,AC_CHECK_LIB(dl,dlopen,found_dlopen=yes))
if test x"$found_dlopen" = "xyes" ; then
- AC_DEFINE(USE_DYNAMIC_LINKING,1,[define to enable the use of extensions])
AC_DEFINE(HAVE_DL_DLOPEN,1,
[Defined when the dlopen function family is available])
AC_SUBST(DLLIBS,"-ldl")
+
+ if test "$try_extensions" = yes ; then
+ AC_DEFINE(USE_DYNAMIC_LINKING,1,
+ [define to enable the use of extensions])
+ fi
+
+ if test "$card_support" = yes ; then
+ AC_DEFINE(ENABLE_CARD_SUPPORT,1,
+ [Define to include the OpenPGP card support])
+ fi
+ else
+ if test "$try_extensions" = yes ; then
+ AC_MSG_WARN([dlopen not found. Disabling extensions.])
+ fi
+
+ if test "$card_support" = yes ; then
+ AC_MSG_WARN([dlopen not found. Disabling OpenPGP card support.])
+ card_support=no
+ fi
fi
-else
- AC_MSG_CHECKING(for dynamic loading)
- AC_MSG_RESULT(has been disabled)
fi
+AM_CONDITIONAL(ENABLE_CARD_SUPPORT, test "$card_support" = yes)
dnl Checks for header files.
AC_HEADER_STDC