aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcus Brinkmann <[email protected]>2006-06-09 10:28:26 +0000
committerMarcus Brinkmann <[email protected]>2006-06-09 10:28:26 +0000
commitaed46885ab9edce4f4e0aaf65c71e4a655379619 (patch)
tree15f053a4e2494755dc71f7422b02210cd257ed8d
parentagent/ (diff)
downloadgnupg-aed46885ab9edce4f4e0aaf65c71e4a655379619.tar.gz
gnupg-aed46885ab9edce4f4e0aaf65c71e4a655379619.zip
2006-06-09 Marcus Brinkmann <[email protected]>
* Makefile.am (gpg_agent_LDADD): Add $(NETLIBS). (gpg_protect_tool_LDADD): Likewise. (gpg_preset_passphrase_LDADD): Likewise.
Diffstat (limited to '')
-rw-r--r--agent/ChangeLog2
-rw-r--r--agent/Makefile.am6
2 files changed, 6 insertions, 2 deletions
diff --git a/agent/ChangeLog b/agent/ChangeLog
index 285cce7f9..999fbae3c 100644
--- a/agent/ChangeLog
+++ b/agent/ChangeLog
@@ -1,6 +1,8 @@
2006-06-09 Marcus Brinkmann <[email protected]>
* Makefile.am (gpg_agent_LDADD): Add $(NETLIBS).
+ (gpg_protect_tool_LDADD): Likewise.
+ (gpg_preset_passphrase_LDADD): Likewise.
2006-04-09 Moritz Schulte <[email protected]>
diff --git a/agent/Makefile.am b/agent/Makefile.am
index 6c7def752..bc96531e0 100644
--- a/agent/Makefile.am
+++ b/agent/Makefile.am
@@ -54,9 +54,10 @@ gpg_protect_tool_SOURCES = \
protect.c \
minip12.c minip12.h
+# Needs $(NETLIBS) for libsimple-pwquery.la.
gpg_protect_tool_LDADD = ../common/libsimple-pwquery.a \
../jnlib/libjnlib.a ../common/libcommon.a ../gl/libgnu.a \
- $(LIBGCRYPT_LIBS) -lgpg-error @LIBINTL@
+ $(LIBGCRYPT_LIBS) -lgpg-error @LIBINTL@ $(NETLIBS)
if HAVE_W32_SYSTEM
gpg_protect_tool_LDADD += -lwsock32
endif
@@ -64,9 +65,10 @@ endif
gpg_preset_passphrase_SOURCES = \
preset-passphrase.c
+# Needs $(NETLIBS) for libsimple-pwquery.la.
gpg_preset_passphrase_LDADD = ../common/libsimple-pwquery.a \
../jnlib/libjnlib.a ../common/libcommon.a ../gl/libgnu.a \
- $(LIBGCRYPT_LIBS) -lgpg-error @LIBINTL@
+ $(LIBGCRYPT_LIBS) -lgpg-error @LIBINTL@ $(NETLIBS)
if HAVE_W32_SYSTEM
gpg_preset_passphrase_LDADD += -lwsock32
endif