diff options
author | Werner Koch <[email protected]> | 2009-12-07 17:12:28 +0000 |
---|---|---|
committer | Werner Koch <[email protected]> | 2009-12-07 17:12:28 +0000 |
commit | a61798d8746238bffefec620ed6bc93e440df3e5 (patch) | |
tree | e56b3dfa322eaca5aeb18046ccc15bc760506966 | |
parent | Use ADNS for PKA and SRV records if no other resolver is available. (diff) | |
download | gnupg-a61798d8746238bffefec620ed6bc93e440df3e5.tar.gz gnupg-a61798d8746238bffefec620ed6bc93e440df3e5.zip |
Fix last configure change.
Diffstat (limited to '')
-rw-r--r-- | ChangeLog | 1 | ||||
-rw-r--r-- | common/pka.c | 2 | ||||
-rw-r--r-- | configure.ac | 9 |
3 files changed, 7 insertions, 5 deletions
@@ -2,6 +2,7 @@ * configure.ac: Check for ADNS before checking for the BIND resolver. + (USE_ADNS): Fallback macro for PKA and CERT lookups. 2009-10-20 Marcus Brinkmann <[email protected]> diff --git a/common/pka.c b/common/pka.c index e78f54367..4f0232324 100644 --- a/common/pka.c +++ b/common/pka.c @@ -1,5 +1,5 @@ /* pka.c - DNS Public Key Association RR access - * Copyright (C) 2005 Free Software Foundation, Inc. + * Copyright (C) 2005, 2009 Free Software Foundation, Inc. * * This file is part of GnuPG. * diff --git a/configure.ac b/configure.ac index 8797e7954..eb03419ac 100644 --- a/configure.ac +++ b/configure.ac @@ -829,13 +829,11 @@ if test x"$use_dns_pka" = xyes || test x"$use_dns_srv" = xyes \ AC_DEFINE(BIND_8_COMPAT,1,[an Apple OSXism]) fi else - use_dns_srv=no - use_dns_pka=no - use_dns_cert=no # If we have no resolver library but ADNS (e.g. under W32) enable the # code parts which can be used with ADNS. + use_dns_cert=no if test x"$have_adns" = xyes ; then - DNSLIB="$ADNSLIBS" + DNSLIBS="$ADNSLIBS" AC_DEFINE(USE_ADNS,1,[Use ADNS as resolver library.]) if test x"$use_dns_srv" = xyes ; then @@ -845,6 +843,9 @@ if test x"$use_dns_pka" = xyes || test x"$use_dns_srv" = xyes \ if test x"$use_dns_pka" = xyes ; then AC_DEFINE(USE_DNS_PKA,1) fi + else + use_dns_srv=no + use_dns_pka=no fi fi |