aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMoritz Schulte <[email protected]>2004-07-27 11:28:10 +0000
committerMoritz Schulte <[email protected]>2004-07-27 11:28:10 +0000
commit97e9cb4e6087a9b0240be6df6c160f5e5bf02adf (patch)
tree7278192757ec09b34b496b6d2d6515f65c15d038
parentpost-release version number bump (diff)
downloadgnupg-97e9cb4e6087a9b0240be6df6c160f5e5bf02adf.tar.gz
gnupg-97e9cb4e6087a9b0240be6df6c160f5e5bf02adf.zip
2004-07-27 Moritz Schulte <[email protected]>
* configure.ac: Check for dlopen in libc and libdl, substitute DL_LIBS accordingly.
Diffstat (limited to '')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bc9f9663d..ca6eaf14f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -461,6 +461,13 @@ AC_CHECK_LIB(usb, usb_find_device,
])
AC_SUBST(LIBUSB_LIBS)
+#
+# Check wether it is necessary to link against libdl.
+#
+LIBS=""
+AC_SEARCH_LIBS(dlopen, c dl,,,)
+DL_LIBS=$LIBS
+AC_SUBST(DL_LIBS)
#
# OpenSC is needed by the SCdaemon - if it is not availbale we can only