aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2009-02-12 17:45:40 +0000
committerWerner Koch <[email protected]>2009-02-12 17:45:40 +0000
commit943f783de7ad3b0a7b8dcd33cc9b767e7d85a1cd (patch)
tree82f965a9a08d15b8591cd72b675f1c6a6be8ca4f
parentFix bug#998. (diff)
downloadgnupg-943f783de7ad3b0a7b8dcd33cc9b767e7d85a1cd.tar.gz
gnupg-943f783de7ad3b0a7b8dcd33cc9b767e7d85a1cd.zip
New scd getinfo subcommand deny_admin
Diffstat (limited to '')
-rw-r--r--NEWS6
-rw-r--r--README.maint3
-rw-r--r--keyserver/Makefile.am2
-rw-r--r--scd/ChangeLog4
-rw-r--r--scd/command.c6
5 files changed, 16 insertions, 5 deletions
diff --git a/NEWS b/NEWS
index 3dcb4e7bf..2a7f4e9f2 100644
--- a/NEWS
+++ b/NEWS
@@ -5,9 +5,9 @@ Noteworthy changes in version 2.0.11 (unreleased)
* SCDAEMON is now aware of the Geldkarte.
- * [gpgsm] The default cipher algorith is now again 3DES. This is due
- to interoperability problems with Outlook 2003 which still can't
- cope with AES.
+ * The default cipher algorithm in GPGSM is now again 3DES. This is
+ due to interoperability problems with Outlook 2003 which still
+ can't cope with AES.
Noteworthy changes in version 2.0.10 (2009-01-12)
diff --git a/README.maint b/README.maint
index 1cbfdd5da..fe1f58c49 100644
--- a/README.maint
+++ b/README.maint
@@ -48,7 +48,8 @@ Release process:
* Update the webpages - at least the file swdb.wml needs an update.
* Add a new headline to NEWS.
* Bump "my_version" up and set "my_issvn" back to "yes" in configure.ac
- * Write an announcement.
+ * Write an announcement. Update https://savannah.gnu.org/projects/gnupg .
+
diff --git a/keyserver/Makefile.am b/keyserver/Makefile.am
index e97fe301a..96cd8d1c2 100644
--- a/keyserver/Makefile.am
+++ b/keyserver/Makefile.am
@@ -69,7 +69,7 @@ gpg2keys_hkp_LDADD = $(common_libs) $(GPG_ERROR_LIBS) $(NETLIBS) $(DNSLIBS) \
$(other_libs)
else
# Note that we need to include all other libs here as well because
-# some compilers don't care about inline fucntions and insert
+# some compilers don't care about inline functions and insert
# references to symbols used in unused inline functions.
gpg2keys_curl_CPPFLAGS = $(LIBCURL_CPPFLAGS) $(AM_CPPFLAGS)
gpg2keys_curl_LDADD = $(common_libs) $(GPG_ERROR_LIBS) $(NETLIBS) $(DNSLIBS) \
diff --git a/scd/ChangeLog b/scd/ChangeLog
index 95ea3f5a8..2265a504e 100644
--- a/scd/ChangeLog
+++ b/scd/ChangeLog
@@ -1,3 +1,7 @@
+2009-02-12 Werner Koch <[email protected]>
+
+ * command.c (cmd_getinfo): Add new subcommand "deny_admin".
+
2009-01-28 Werner Koch <[email protected]>
* scdaemon.c (main): Make --allow-admin the default and make the
diff --git a/scd/command.c b/scd/command.c
index 8ebcdb323..f3e374c39 100644
--- a/scd/command.c
+++ b/scd/command.c
@@ -1557,6 +1557,10 @@ cmd_unlock (assuan_context_t ctx, char *line)
reader_list - Return a list of detected card readers. Does
currently only work with the internal CCID driver.
+
+ deny_admin - Returns OK if admin commands are not allowed or
+ GPG_ERR_GENERAL if admin commands are allowed.
+
*/
static int
@@ -1622,6 +1626,8 @@ cmd_getinfo (assuan_context_t ctx, char *line)
rc = gpg_error (GPG_ERR_NO_DATA);
xfree (s);
}
+ else if (!strcmp (line, "deny_admin"))
+ rc = opt.allow_admin? gpg_error (GPG_ERR_GENERAL) : 0;
else
rc = set_error (GPG_ERR_ASS_PARAMETER, "unknown value for WHAT");
return rc;