aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2003-02-12 04:45:51 +0000
committerDavid Shaw <[email protected]>2003-02-12 04:45:51 +0000
commit911cc7e6ab85bb0622bd54a639941b407f0366e7 (patch)
treea3b6c18a14eddd8ed44ce93a2f29d5042ca04ed1
parent* Makefile.am: Use a local copy of libexecdir along with @PACKAGE@ so it (diff)
downloadgnupg-911cc7e6ab85bb0622bd54a639941b407f0366e7.tar.gz
gnupg-911cc7e6ab85bb0622bd54a639941b407f0366e7.zip
* types.h: Try and use uint64_t for a 64-bit type.
Diffstat (limited to '')
-rw-r--r--include/ChangeLog4
-rw-r--r--include/types.h7
2 files changed, 11 insertions, 0 deletions
diff --git a/include/ChangeLog b/include/ChangeLog
index f043ddc5c..97ae7b63f 100644
--- a/include/ChangeLog
+++ b/include/ChangeLog
@@ -1,3 +1,7 @@
+2003-02-11 David Shaw <[email protected]>
+
+ * types.h: Try and use uint64_t for a 64-bit type.
+
2003-02-04 David Shaw <[email protected]>
* cipher.h: Add constants for new SHAs.
diff --git a/include/types.h b/include/types.h
index b41109ee5..0b4f6a485 100644
--- a/include/types.h
+++ b/include/types.h
@@ -21,6 +21,10 @@
#ifndef G10_TYPES_H
#define G10_TYPES_H
+#if HAVE_INTTYPES_H
+/* For uint64_t */
+#include <inttypes.h>
+#endif
/* The AC_CHECK_SIZEOF() in configure fails for some machines.
* we provide some fallback values here */
@@ -106,6 +110,9 @@
#elif SIZEOF_UNSIGNED_LONG_LONG == 8
typedef unsigned long long u64;
#define HAVE_U64_TYPEDEF
+ #elif SIZEOF_UINT64_T == 8
+ typedef uint64_t u64;
+ #define HAVE_U64_TYPEDEF
#endif
#endif