aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2006-05-23 15:32:57 +0000
committerDavid Shaw <[email protected]>2006-05-23 15:32:57 +0000
commit8fa55e28fee4429bf333572a431e800618f077d4 (patch)
tree46b562aa9f919c7277232deba7ffb25c8ebabf5f
parent* parse-packet.c (dump_sig_subpkt, parse_signature), build-packet.c (diff)
downloadgnupg-8fa55e28fee4429bf333572a431e800618f077d4.tar.gz
gnupg-8fa55e28fee4429bf333572a431e800618f077d4.zip
* configure.ac: Add --disable-optimization. This is handy for debugging
so the compiler doesn't rearrange things and eliminate variables.
Diffstat (limited to '')
-rw-r--r--ChangeLog6
-rw-r--r--configure.ac9
2 files changed, 15 insertions, 0 deletions
diff --git a/ChangeLog b/ChangeLog
index 64f5a7ecb..55537b99b 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,9 @@
+2006-05-23 David Shaw <[email protected]>
+
+ * configure.ac: Add --disable-optimization. This is handy for
+ debugging so the compiler doesn't rearrange things and eliminate
+ variables.
+
2006-05-22 Marcus Brinkmann <[email protected]>
* configure.ac: Remove check for noexecstack and invoke
diff --git a/configure.ac b/configure.ac
index a6adfc26a..680414595 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1264,6 +1264,15 @@ if test "$GCC" = yes; then
CFLAGS="$CFLAGS -Wall"
fi
+ # This is handy for debugging so the compiler doesn't rearrange
+ # things and eliminate variables.
+ AC_ARG_ENABLE(optimization,
+ AC_HELP_STRING([--disable-optimization],
+ [disable compiler optimization]),
+ [if test $enableval = no ; then
+ CFLAGS=`echo $CFLAGS | sed 's/-O[[0-9]]//'`
+ fi])
+
AC_MSG_CHECKING([if gcc supports -Wno-pointer-sign])
_gcc_cflags_save=$CFLAGS