aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2003-07-04 09:40:19 +0000
committerWerner Koch <[email protected]>2003-07-04 09:40:19 +0000
commit89a3dbae85f4541db77c51a4ea768c60e66ec292 (patch)
treeacfbe8b7f9d4432b44869d497d19e062c57f1c75
parent* cipher.h (DBG_CIPHER,g10c_debug_mode): Removed. (diff)
downloadgnupg-89a3dbae85f4541db77c51a4ea768c60e66ec292.tar.gz
gnupg-89a3dbae85f4541db77c51a4ea768c60e66ec292.zip
Minor changes to make make dist work correctly.
Diffstat (limited to '')
-rw-r--r--Makefile.am16
-rw-r--r--include/distfiles2
2 files changed, 14 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 74e622051..9f5c443d5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -44,10 +44,22 @@ else
scd =
endif
-SUBDIRS = m4 intl jnlib common kbx ${gpg} ${sm} ${agent} ${scd} po doc tests
+SUBDIRS = m4 intl jnlib common kbx \
+ ${gpg} ${sm} ${agent} ${scd} po doc tests
+
dist-hook:
- @set -e; echo "$(VERSION)" > $(distdir)/VERSION
+ @set -e; \
+ for file in `cd $(top_srcdir); \
+ find scripts include -type f -name distfiles`; do \
+ dir=`dirname $$file` ; $(mkinstalldirs) $(distdir)/$$dir ; \
+ for i in distfiles `cat $(top_srcdir)/$$file` ; do \
+ ln $(top_srcdir)/$$dir/$$i $(distdir)/$$dir/$$i 2> /dev/null \
+ || cp -p $(top_srcdir)/$$dir/$$i $(distdir)/$$dir/$$i; \
+ done ; \
+ done
+ echo "$(VERSION)" > $(distdir)/VERSION
+
diff --git a/include/distfiles b/include/distfiles
index 20a9091e6..b11749d78 100644
--- a/include/distfiles
+++ b/include/distfiles
@@ -1,9 +1,7 @@
cipher.h
errors.h
-iobuf.h
memory.h
mpi.h
-ttyio.h
types.h
util.h
i18n.h