aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2016-06-04 16:45:37 +0000
committerWerner Koch <[email protected]>2016-06-04 16:45:37 +0000
commit79b7a8a9e0d41b743ceaee20dc47294359fe0d44 (patch)
treec230b67d361e11c8b224e186bf403db704f46179
parentgpg: Add the fingerprint to KEY_CREATED for subkeys. (diff)
downloadgnupg-79b7a8a9e0d41b743ceaee20dc47294359fe0d44.tar.gz
gnupg-79b7a8a9e0d41b743ceaee20dc47294359fe0d44.zip
w32: Require --enable-build-timestamp for the BUILD_HOSTNAME.
* configure.ac (BUILD_HOSTNAME): Set to "<anon>" bey default. * build-aux/speedo.mk (speedo_pkg_gnupg_configure): Add --enable-build-timestamp. -- Debian-bug-id: 826309 Signed-off-by: Werner Koch <[email protected]>
Diffstat (limited to '')
-rw-r--r--build-aux/speedo.mk4
-rw-r--r--configure.ac7
2 files changed, 7 insertions, 4 deletions
diff --git a/build-aux/speedo.mk b/build-aux/speedo.mk
index d286655c3..67ccbb454 100644
--- a/build-aux/speedo.mk
+++ b/build-aux/speedo.mk
@@ -448,7 +448,9 @@ speedo_pkg_libgcrypt_configure = --disable-static
speedo_pkg_libksba_configure = --disable-static
ifeq ($(TARGETOS),w32)
-speedo_pkg_gnupg_configure = --enable-gpg2-is-gpg --disable-g13 --disable-ntbtls
+speedo_pkg_gnupg_configure = \
+ --enable-gpg2-is-gpg --disable-g13 --disable-ntbtls \
+ --enable-build-timestamp
else
speedo_pkg_gnupg_configure = --disable-g13
endif
diff --git a/configure.ac b/configure.ac
index 07d728a78..1b8a6fc8b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1776,12 +1776,13 @@ AC_ARG_ENABLE([build-timestamp],
BUILD_TIMESTAMP=`date -u +%Y-%m-%dT%H:%M+0000 2>/dev/null || date`
else
BUILD_TIMESTAMP="$enableval"
- fi],
- [BUILD_TIMESTAMP="<none>"])
+ fi
+ BUILD_HOSTNAME="$ac_hostname"],
+ [BUILD_TIMESTAMP="<none>"
+ BUILD_HOSTNAME="<anon>"])
AC_SUBST(BUILD_TIMESTAMP)
AC_DEFINE_UNQUOTED(BUILD_TIMESTAMP, "$BUILD_TIMESTAMP",
[The time this package was configured for a build])
-BUILD_HOSTNAME="$ac_hostname"
AC_SUBST(BUILD_HOSTNAME)