aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcus Brinkmann <[email protected]>2012-02-16 16:51:20 +0000
committerMarcus Brinkmann <[email protected]>2012-02-16 17:03:29 +0000
commit76ff42ef8d1232dd36bf48c1020b0b9b2afb1c7d (patch)
tree93783642df3ed82429965c0bba1152af39370451
parentagent: Add pin length field to the shadowed private key format. (diff)
downloadgnupg-76ff42ef8d1232dd36bf48c1020b0b9b2afb1c7d.tar.gz
gnupg-76ff42ef8d1232dd36bf48c1020b0b9b2afb1c7d.zip
Check for lber and link dirmngr_ldap to it.
* configure.ac (LBER_LIBS, HAVE_LBER): New variables, check for lber. * dirmngr/Makefile.am (dirmngr_lda_LDADD): Add $(LBER_LIBS).
Diffstat (limited to '')
-rw-r--r--configure.ac7
-rw-r--r--dirmngr/Makefile.am3
2 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 47c6d1202..6aadaa266 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1009,7 +1009,14 @@ AM_CONDITIONAL(USE_DNS_SRV, test x"$use_dns_srv" = xyes)
#
if test "$try_ks_ldap" = yes || test "$build_dirmngr" = "yes" ; then
GNUPG_CHECK_LDAP($NETLIBS)
+ AC_CHECK_LIB(lber, ber_free,
+ [ LBER_LIBS="$LBER_LIBS -llber"
+ AC_DEFINE(HAVE_LBER,1,
+ [defined if liblber is available])
+ have_lber=yes
+ ])
fi
+AC_SUBST(LBER_LIBS)
#
# Check for curl. We fake the curl API if libcurl isn't installed.
diff --git a/dirmngr/Makefile.am b/dirmngr/Makefile.am
index c5f073e3b..7c431658e 100644
--- a/dirmngr/Makefile.am
+++ b/dirmngr/Makefile.am
@@ -72,7 +72,8 @@ dirmngr_ldap_SOURCES = dirmngr_ldap.c $(ldap_url)
dirmngr_ldap_CFLAGS = $(GPG_ERROR_CFLAGS) $(LIBGCRYPT_CFLAGS)
dirmngr_ldap_LDFLAGS =
dirmngr_ldap_LDADD = $(libcommon) no-libgcrypt.o ../gl/libgnu.a $(DNSLIBS) \
- $(GPG_ERROR_LIBS) $(LDAPLIBS) $(LIBINTL) $(LIBICONV)
+ $(GPG_ERROR_LIBS) $(LDAPLIBS) $(LBER_LIBS) $(LIBINTL) \
+ $(LIBICONV)
endif
dirmngr_client_SOURCES = dirmngr-client.c