aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustus Winter <[email protected]>2017-03-15 09:51:03 +0000
committerJustus Winter <[email protected]>2017-03-15 09:51:03 +0000
commit6993e42088c191f18468317ba2b5b8fbc8c3edff (patch)
treea4e3f73a8975eb7d65fa33d79e482e39416167ef
parentg10: Fix check of serialno. (diff)
downloadgnupg-6993e42088c191f18468317ba2b5b8fbc8c3edff.tar.gz
gnupg-6993e42088c191f18468317ba2b5b8fbc8c3edff.zip
build: Remove '--disable-tools' configuration option.
* Makefile.am (SUBDIRS): Unconditionally include 'tools'. * configure.ac: Remove '--disable-tools' configuration option. -- gpgconf is a core component nowadays and is always required. GnuPG-bug-id: 2993 Signed-off-by: Justus Winter <[email protected]>
Diffstat (limited to '')
-rw-r--r--Makefile.am7
-rw-r--r--configure.ac2
2 files changed, 1 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index 71e691afd..7d023c1af 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -81,11 +81,6 @@ dirmngr = dirmngr
else
dirmngr =
endif
-if BUILD_TOOLS
-tools = tools
-else
-tools =
-endif
if BUILD_DOC
doc = doc
else
@@ -94,7 +89,7 @@ endif
SUBDIRS = m4 common kbx \
${gpg} ${sm} ${agent} ${scd} ${g13} ${dirmngr} \
- ${tools} po ${doc} tests
+ tools po ${doc} tests
dist_doc_DATA = README
diff --git a/configure.ac b/configure.ac
index bd618e577..df7a059e5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -126,7 +126,6 @@ build_agent=yes
GNUPG_BUILD_PROGRAM(scdaemon, yes)
GNUPG_BUILD_PROGRAM(g13, no)
GNUPG_BUILD_PROGRAM(dirmngr, yes)
-GNUPG_BUILD_PROGRAM(tools, yes)
GNUPG_BUILD_PROGRAM(doc, yes)
GNUPG_BUILD_PROGRAM(symcryptrun, no)
# We use gpgtar to unpack test data, hence we always build it. If the
@@ -1706,7 +1705,6 @@ AM_CONDITIONAL(BUILD_AGENT, test "$build_agent" = "yes")
AM_CONDITIONAL(BUILD_SCDAEMON, test "$build_scdaemon" = "yes")
AM_CONDITIONAL(BUILD_G13, test "$build_g13" = "yes")
AM_CONDITIONAL(BUILD_DIRMNGR, test "$build_dirmngr" = "yes")
-AM_CONDITIONAL(BUILD_TOOLS, test "$build_tools" = "yes")
AM_CONDITIONAL(BUILD_DOC, test "$build_doc" = "yes")
AM_CONDITIONAL(BUILD_SYMCRYPTRUN, test "$build_symcryptrun" = "yes")
AM_CONDITIONAL(BUILD_GPGTAR, test "$build_gpgtar" = "yes")