aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2005-01-18 03:54:46 +0000
committerDavid Shaw <[email protected]>2005-01-18 03:54:46 +0000
commit586be6711ef6190ba263826632701f70f32eab8c (patch)
tree440bae616639e642e50251a67b066a1a52c6e38d
parentSame for (diff)
downloadgnupg-586be6711ef6190ba263826632701f70f32eab8c.tar.gz
gnupg-586be6711ef6190ba263826632701f70f32eab8c.zip
* libcurl.m4: Use LIBCURL_CPPFLAGS and not LIBCURL_INCLUDES to match
automake syntax.
Diffstat (limited to '')
-rw-r--r--m4/ChangeLog5
-rw-r--r--m4/libcurl.m410
2 files changed, 10 insertions, 5 deletions
diff --git a/m4/ChangeLog b/m4/ChangeLog
index 331d26d2a..d13801996 100644
--- a/m4/ChangeLog
+++ b/m4/ChangeLog
@@ -1,3 +1,8 @@
+2005-01-17 David Shaw <[email protected]>
+
+ * libcurl.m4: Use LIBCURL_CPPFLAGS and not LIBCURL_INCLUDES to
+ match automake syntax.
+
2005-01-03 David Shaw <[email protected]>
* Makefile.am, libusb.m4: New libusb check macro.
diff --git a/m4/libcurl.m4 b/m4/libcurl.m4
index 048b1f89f..ab87c9e74 100644
--- a/m4/libcurl.m4
+++ b/m4/libcurl.m4
@@ -13,7 +13,7 @@
# --without-libcurl does run ACTION-IF-NO.
#
# This macro defines HAVE_LIBCURL if a working libcurl setup is found,
-# and sets @LIBCURL@ and @LIBCURL_INCLUDES@ to the necessary values.
+# and sets @LIBCURL@ and @LIBCURL_CPPFLAGS@ to the necessary values.
# Other useful defines are LIBCURL_FEATURE_xxx where xxx are the
# various features supported by libcurl, and LIBCURL_PROTOCOL_yyy
# where yyy are the various protocols supported by libcurl. Both xxx
@@ -82,8 +82,8 @@ AC_DEFUN([LIBCURL_CHECK_CONFIG],
fi
if test $_libcurl_wanted -eq 0 || test x$libcurl_cv_lib_version_ok = xyes ; then
- if test x"$LIBCURL_INCLUDES" = "x" ; then
- LIBCURL_INCLUDES=`$_libcurl_config --cflags`
+ if test x"$LIBCURL_CPPFLAGS" = "x" ; then
+ LIBCURL_CPPFLAGS=`$_libcurl_config --cflags`
fi
if test x"$LIBCURL" = "x" ; then
LIBCURL=`$_libcurl_config --libs`
@@ -124,7 +124,7 @@ AC_DEFUN([LIBCURL_CHECK_CONFIG],
[libcurl_cv_lib_curl_usable],
[
_libcurl_save_cppflags=$CPPFLAGS
- CPPFLAGS="$CPPFLAGS $LIBCURL_INCLUDES"
+ CPPFLAGS="$CPPFLAGS $LIBCURL_CPPFLAGS"
_libcurl_save_ldflags=$LDFLAGS
LDFLAGS="$LDFLAGS $LIBCURL"
@@ -150,7 +150,7 @@ x=CURLOPT_VERBOSE;
if test $libcurl_cv_lib_curl_usable = yes ; then
AC_DEFINE(HAVE_LIBCURL,1,
[Define to 1 if you have a functional curl library.])
- AC_SUBST(LIBCURL_INCLUDES)
+ AC_SUBST(LIBCURL_CPPFLAGS)
AC_SUBST(LIBCURL)
for _libcurl_feature in $_libcurl_features ; do