aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2014-01-09 14:36:35 +0000
committerWerner Koch <[email protected]>2014-01-09 14:36:35 +0000
commit477aabaf753f987987f7a2e1f999a499ea3bd103 (patch)
treeecc0cab2aadc9be69a19aa2afd9c092941626be2
parentAdd --enable-silent-rules stuff. (diff)
downloadgnupg-477aabaf753f987987f7a2e1f999a499ea3bd103.tar.gz
gnupg-477aabaf753f987987f7a2e1f999a499ea3bd103.zip
Fix test for zlib.
* configure.ac (HAVE_ZLIB): Define only if found.
Diffstat (limited to '')
-rw-r--r--configure.ac13
1 files changed, 7 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 96b023a39..03a2c272d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1362,12 +1362,13 @@ if test "$use_zip" = yes ; then
])
AC_CHECK_HEADER(zlib.h,
- AC_CHECK_LIB(z, deflateInit2_,
- ZLIBS="-lz",
- CPPFLAGS=${_cppflags} LDFLAGS=${_ldflags}),
- CPPFLAGS=${_cppflags} LDFLAGS=${_ldflags})
-
- AC_DEFINE(HAVE_ZIP,1, [Defined if ZIP and ZLIB are supported])
+ AC_CHECK_LIB(z, deflateInit2_,
+ [
+ ZLIBS="-lz"
+ AC_DEFINE(HAVE_ZIP,1, [Defined if ZIP and ZLIB are supported])
+ ],
+ CPPFLAGS=${_cppflags} LDFLAGS=${_ldflags}),
+ CPPFLAGS=${_cppflags} LDFLAGS=${_ldflags})
fi