aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2015-05-15 11:20:52 +0000
committerWerner Koch <[email protected]>2015-05-15 11:20:52 +0000
commit43ea8f5d884dd108bb27d8e1610fa28802295a06 (patch)
treeb3dbab95d4cc7c23f9a74e625e395baed70cdb5a
parentPost release updates. (diff)
downloadgnupg-43ea8f5d884dd108bb27d8e1610fa28802295a06.tar.gz
gnupg-43ea8f5d884dd108bb27d8e1610fa28802295a06.zip
build: Make --disable-gpgsm work.
* Makefile.am: Always build kbx/ * g10/Makefile.am (AM_CFLAGS): Include KSBA_CFLAGS. -- Note that "make check" still prints a warning. Signed-off-by: Werner Koch <[email protected]>
Diffstat (limited to '')
-rw-r--r--Makefile.am9
-rw-r--r--NEWS4
-rw-r--r--g10/Makefile.am5
3 files changed, 7 insertions, 11 deletions
diff --git a/Makefile.am b/Makefile.am
index 57529b6c5..0613545dd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -47,13 +47,6 @@ EXTRA_DIST = build-aux/config.rpath build-aux/potomo autogen.sh autogen.rc \
DISTCLEANFILES = g10defs.h
-if BUILD_GPGSM
-kbx = kbx
-else
-kbx =
-endif
-
-
if BUILD_GPG
gpg = g10
else
@@ -101,7 +94,7 @@ else
tests =
endif
-SUBDIRS = m4 common ${kbx} \
+SUBDIRS = m4 common kbx \
${gpg} ${sm} ${agent} ${scd} ${g13} ${dirmngr} \
${tools} po ${doc} ${tests}
diff --git a/NEWS b/NEWS
index 4286792f3..b59be512e 100644
--- a/NEWS
+++ b/NEWS
@@ -5,13 +5,13 @@ Noteworthy changes in version 2.1.5 (unreleased)
Noteworthy changes in version 2.1.4 (2015-05-12)
------------------------------------------------
- * gpg: Add command --quick-adduid to non-interacitivly add a new user
+ * gpg: Add command --quick-adduid to non-interactively add a new user
id to an existing key.
* gpg: Do no enable honor-keyserver-url by default. Make it work if
enabled.
- * gpg: Display the serial number in the --card-staus output again.
+ * gpg: Display the serial number in the --card-status output again.
* agent: Support for external password managers.
Add option --no-allow-external-cache.
diff --git a/g10/Makefile.am b/g10/Makefile.am
index ca99314b7..ea4afc878 100644
--- a/g10/Makefile.am
+++ b/g10/Makefile.am
@@ -25,7 +25,10 @@ AM_CPPFLAGS = -I$(top_srcdir)/common
include $(top_srcdir)/am/cmacros.am
-AM_CFLAGS = $(LIBGCRYPT_CFLAGS) $(LIBASSUAN_CFLAGS) $(GPG_ERROR_CFLAGS)
+# We need KSBA_CFLAGS because that is included by keybox.h. See also
+# comments below for libksba.
+AM_CFLAGS = $(LIBGCRYPT_CFLAGS) $(KSBA_CFLAGS) \
+ $(LIBASSUAN_CFLAGS) $(GPG_ERROR_CFLAGS)
needed_libs = ../kbx/libkeybox.a $(libcommon)