aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2004-10-28 18:57:50 +0000
committerWerner Koch <[email protected]>2004-10-28 18:57:50 +0000
commit41f46fb0622010be782cd0b729350bd5aa862791 (patch)
tree8cc6ae38b557ba02a392f4e82d218384ee907c96
parentpost release preparations (diff)
downloadgnupg-41f46fb0622010be782cd0b729350bd5aa862791.tar.gz
gnupg-41f46fb0622010be782cd0b729350bd5aa862791.zip
Inlcude LIBICONV
Diffstat (limited to '')
-rw-r--r--g10/ChangeLog5
-rw-r--r--g10/Makefile.am3
-rw-r--r--keyserver/ChangeLog9
-rw-r--r--keyserver/Makefile.am10
-rw-r--r--tools/ChangeLog5
-rw-r--r--tools/Makefile.am11
6 files changed, 33 insertions, 10 deletions
diff --git a/g10/ChangeLog b/g10/ChangeLog
index f43a6384c..2dadee08f 100644
--- a/g10/ChangeLog
+++ b/g10/ChangeLog
@@ -1,5 +1,10 @@
2004-10-28 Werner Koch <[email protected]>
+ * Makefile.am (other_libs): New. Also include LIBICONV. Noted by
+ Tim Mooney.
+
+2004-10-28 Werner Koch <[email protected]>
+
* apdu.c (open_pcsc_reader): Removed bad free in error handler.
2004-10-27 David Shaw <[email protected]>
diff --git a/g10/Makefile.am b/g10/Makefile.am
index 2c5d82020..a3f2ff6e9 100644
--- a/g10/Makefile.am
+++ b/g10/Makefile.am
@@ -28,6 +28,7 @@ if ! HAVE_DOSISH_SYSTEM
AM_CFLAGS = -DGNUPG_LIBEXECDIR="\"$(libexecdir)\""
endif
needed_libs = ../cipher/libcipher.a ../mpi/libmpi.a ../util/libutil.a
+other_libs = $(LIBICONV) $(LIBINTL) $(CAPLIBS)
#noinst_PROGRAMS = gpgd
bin_PROGRAMS = gpg gpgv
@@ -131,7 +132,7 @@ gpgv_SOURCES = gpgv.c \
# ks-db.h \
# $(common_source)
-LDADD = $(needed_libs) @LIBINTL@ @CAPLIBS@ @ZLIBS@ @W32LIBS@
+LDADD = $(needed_libs) $(other_libs) @ZLIBS@ @W32LIBS@
gpg_LDADD = $(LDADD) @DLLIBS@ @NETLIBS@ @LIBUSB_LIBS@
$(PROGRAMS): $(needed_libs)
diff --git a/keyserver/ChangeLog b/keyserver/ChangeLog
index 81a657755..1fea13566 100644
--- a/keyserver/ChangeLog
+++ b/keyserver/ChangeLog
@@ -1,3 +1,12 @@
+2004-10-28 Werner Koch <[email protected]>
+
+ * Makefile.am (other_libs): New. Also include LIBICONV. Noted by
+ Tim Mooney.
+
+2004-10-28 Werner Koch <[email protected]>
+
+ * Makefile.am (other_libs):
+
2004-10-18 David Shaw <[email protected]>
* gpgkeys_hkp.c (send_key, get_key, search_key): Use "hkp" instead
diff --git a/keyserver/Makefile.am b/keyserver/Makefile.am
index 9418b1c39..37698ca6a 100644
--- a/keyserver/Makefile.am
+++ b/keyserver/Makefile.am
@@ -32,10 +32,12 @@ gpgkeys_hkp_SOURCES = gpgkeys_hkp.c ksutil.c ksutil.h
gpgkeys_http_SOURCES = gpgkeys_http.c ksutil.c ksutil.h
gpgkeys_finger_SOURCES = gpgkeys_finger.c ksutil.c ksutil.h
-gpgkeys_ldap_LDADD = ../util/libutil.a @LDAPLIBS@ @NETLIBS@ @LIBINTL@ @CAPLIBS@ @GETOPT@ @W32LIBS@
-gpgkeys_hkp_LDADD = ../util/libutil.a @NETLIBS@ @SRVLIBS@ @LIBINTL@ @CAPLIBS@ @GETOPT@ @W32LIBS@
-gpgkeys_http_LDADD = ../util/libutil.a @NETLIBS@ @SRVLIBS@ @LIBINTL@ @CAPLIBS@ @GETOPT@ @W32LIBS@
-gpgkeys_finger_LDADD = ../util/libutil.a @NETLIBS@ @LIBINTL@ @CAPLIBS@ @GETOPT@ @W32LIBS@
+other_libs = $(LIBICONV) $(LIBINTL) $(CAPLIBS)
+
+gpgkeys_ldap_LDADD = ../util/libutil.a @LDAPLIBS@ @NETLIBS@ $(other_libs) @GETOPT@ @W32LIBS@
+gpgkeys_hkp_LDADD = ../util/libutil.a @NETLIBS@ @SRVLIBS@ $(other_libs) @GETOPT@ @W32LIBS@
+gpgkeys_http_LDADD = ../util/libutil.a @NETLIBS@ @SRVLIBS@ $(other_libs) @GETOPT@ @W32LIBS@
+gpgkeys_finger_LDADD = ../util/libutil.a @NETLIBS@ $(other_libs) @GETOPT@ @W32LIBS@
install-exec-hook:
if GPGKEYS_LDAP
diff --git a/tools/ChangeLog b/tools/ChangeLog
index f8299725a..186ac9a40 100644
--- a/tools/ChangeLog
+++ b/tools/ChangeLog
@@ -1,3 +1,8 @@
+2004-10-28 Werner Koch <[email protected]>
+
+ * Makefile.am (other_libs): New. Also include LIBICONV. Noted by
+ Tim Mooney.
+
2004-10-01 Werner Koch <[email protected]>
* bftest.c (i18n_init): Always use LC_ALL.
diff --git a/tools/Makefile.am b/tools/Makefile.am
index e52d49d36..4cb7e74a4 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -20,14 +20,15 @@
EXTRA_DIST = lspgpot ring-a-party mail-signed-keys convert-from-106
INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)/intl
-needed_libs = ../cipher/libcipher.a ../mpi/libmpi.a ../util/libutil.a
+needed_libs = ../cipher/libcipher.a ../mpi/libmpi.a ../util/libutil.a
+other_libs = $(LIBICONV) $(LIBINTL) $(CAPLIBS)
bin_PROGRAMS = gpgsplit
noinst_PROGRAMS = mpicalc bftest clean-sat mk-tdata shmtest
-gpgsplit_LDADD = $(needed_libs) @LIBINTL@ @CAPLIBS@ @ZLIBS@
-mpicalc_LDADD = $(needed_libs) @LIBINTL@ @CAPLIBS@ @W32LIBS@
-bftest_LDADD = $(needed_libs) @LIBINTL@ @CAPLIBS@ @W32LIBS@ @DLLIBS@ @NETLIBS@
-shmtest_LDADD = $(needed_libs) @LIBINTL@ @CAPLIBS@
+gpgsplit_LDADD = $(needed_libs) $(other_libs) @ZLIBS@
+mpicalc_LDADD = $(needed_libs) $(other_libs) @W32LIBS@
+bftest_LDADD = $(needed_libs) $(other_libs) @W32LIBS@ @DLLIBS@ @NETLIBS@
+shmtest_LDADD = $(needed_libs) $(other_libs)
gpgsplit mpicalc bftest shmtest: $(needed_libs)