aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2005-03-21 15:24:48 +0000
committerWerner Koch <[email protected]>2005-03-21 15:24:48 +0000
commit31135aff140c9fa2364d7a485c06b05815a958c5 (patch)
treeab157f7ac7297deb6720ac621d1059da1e5a1d6d
parent* readline.m4: Check for completion functionality. (diff)
downloadgnupg-31135aff140c9fa2364d7a485c06b05815a958c5.tar.gz
gnupg-31135aff140c9fa2364d7a485c06b05815a958c5.zip
* keyedit.c (command_generator, keyedit_completion): Changed
indentation. * card-util.c (command_generator, card_edit_completion): Ditto.
Diffstat (limited to '')
-rw-r--r--g10/ChangeLog10
-rw-r--r--g10/card-util.c25
-rw-r--r--g10/keyedit.c12
-rw-r--r--util/ttyio.c2
4 files changed, 34 insertions, 15 deletions
diff --git a/g10/ChangeLog b/g10/ChangeLog
index 32430a131..f9f60ed7c 100644
--- a/g10/ChangeLog
+++ b/g10/ChangeLog
@@ -1,3 +1,9 @@
+2005-03-21 Werner Koch <[email protected]>
+
+ * keyedit.c (command_generator, keyedit_completion): Changed
+ indentation.
+ * card-util.c (command_generator, card_edit_completion): Ditto.
+
2005-03-19 David Shaw <[email protected]>
* card-util.c (command_generator, card_edit_completion)
@@ -20,8 +26,8 @@
* Makefile.am: Calculate GNUPG_LIBEXECDIR directly. Do not
redefine $libexecdir.
- * options.h, keyserver.c (parse_keyserver_options,
- keyserver_spawn): Don't treat 'verbose' and 'include-disabled' as
+ * options.h, keyserver.c (parse_keyserver_options)
+ (keyserver_spawn): Don't treat 'verbose' and 'include-disabled' as
special. Just pass them through silently to the keyserver helper.
2005-03-16 Werner Koch <[email protected]>
diff --git a/g10/card-util.c b/g10/card-util.c
index a0adca9f1..da786f7a8 100644
--- a/g10/card-util.c
+++ b/g10/card-util.c
@@ -27,7 +27,7 @@
#if GNUPG_MAJOR_VERSION != 1
#include "gpg.h"
-#endif
+#endif /*GNUPG_MAJOR_VERSION != 1*/
#include "util.h"
#include "i18n.h"
#include "ttyio.h"
@@ -39,11 +39,11 @@
#ifdef HAVE_LIBREADLINE
#include <stdio.h>
#include <readline/readline.h>
-#endif
+#endif /*HAVE_LIBREADLINE*/
#include "cardglue.h"
-#else
+#else /*GNUPG_MAJOR_VERSION!=1*/
#include "call-agent.h"
-#endif
+#endif /*GNUPG_MAJOR_VERSION!=1*/
#define CONTROL_D ('D' - 'A' + 1)
@@ -1275,6 +1275,10 @@ card_store_subkey (KBNODE node, int use)
#endif
}
+
+
+/* Data used by the command parser. This needs to be outside of the
+ function scope to allow readline based command completion. */
enum cmdids
{
cmdNOP = 0,
@@ -1315,11 +1319,13 @@ static struct
{ NULL, cmdINVCMD, 0, NULL }
};
+
#if GNUPG_MAJOR_VERSION == 1 && defined (HAVE_LIBREADLINE)
/* These two functions are used by readline for command completion. */
-static char *command_generator(const char *text,int state)
+static char *
+command_generator(const char *text,int state)
{
static int list_index,len;
const char *name;
@@ -1344,7 +1350,8 @@ static char *command_generator(const char *text,int state)
return NULL;
}
-static char **card_edit_completion(const char *text, int start, int end)
+static char **
+card_edit_completion(const char *text, int start, int end)
{
/* If we are at the start of a line, we try and command-complete.
If not, just do nothing for now. */
@@ -1356,7 +1363,7 @@ static char **card_edit_completion(const char *text, int start, int end)
return NULL;
}
-#endif
+#endif /* GNUPG_MAJOR_VERSION == 1 && HAVE_LIBREADLINE */
/* Menu to edit all user changeable values on an OpenPGP card. Only
Key creation is not handled here. */
@@ -1424,12 +1431,12 @@ card_edit (STRLIST commands)
if (!have_commands)
{
#if GNUPG_MAJOR_VERSION == 1
- tty_enable_completion(card_edit_completion);
+ tty_enable_completion (card_edit_completion);
#endif
answer = cpr_get_no_help("cardedit.prompt", _("Command> "));
cpr_kill_prompt();
#if GNUPG_MAJOR_VERSION == 1
- tty_disable_completion();
+ tty_disable_completion ();
#endif
}
trim_spaces(answer);
diff --git a/g10/keyedit.c b/g10/keyedit.c
index 5a2d54849..bf5ab77d0 100644
--- a/g10/keyedit.c
+++ b/g10/keyedit.c
@@ -1280,6 +1280,7 @@ parse_sign_type(const char *str,int *localsig,int *nonrevokesig,int *trustsig)
return 1;
}
+
/****************
* Menu driven key editor. If seckey_check is true, then a secret key
* that matches username will be looked for. If it is false, not all
@@ -1408,11 +1409,13 @@ static struct
{ NULL, cmdNONE, 0, NULL }
};
+
#ifdef HAVE_LIBREADLINE
/* These two functions are used by readline for command completion. */
-static char *command_generator(const char *text,int state)
+static char *
+command_generator(const char *text,int state)
{
static int list_index,len;
const char *name;
@@ -1437,7 +1440,8 @@ static char *command_generator(const char *text,int state)
return NULL;
}
-static char **keyedit_completion(const char *text, int start, int end)
+static char **
+keyedit_completion(const char *text, int start, int end)
{
/* If we are at the start of a line, we try and command-complete.
If not, just do nothing for now. */
@@ -1449,7 +1453,8 @@ static char **keyedit_completion(const char *text, int start, int end)
return NULL;
}
-#endif
+#endif /* HAVE_LIBREADLINE */
+
void
keyedit_menu( const char *username, STRLIST locusr,
@@ -2163,6 +2168,7 @@ keyedit_menu( const char *username, STRLIST locusr,
}
+
/****************
* show preferences of a public keyblock.
*/
diff --git a/util/ttyio.c b/util/ttyio.c
index 5feab726e..08f4d3373 100644
--- a/util/ttyio.c
+++ b/util/ttyio.c
@@ -191,7 +191,7 @@ tty_disable_completion(void)
init_ttyfp();
rl_inhibit_completion=1;
}
-#endif
+#endif /*HAVE_LIBREADLINE*/
int
tty_batchmode( int onoff )