aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustus Winter <[email protected]>2016-09-27 13:54:56 +0000
committerJustus Winter <[email protected]>2016-09-27 13:54:56 +0000
commit2b23a321ac0b07beeac1dfa8d71f223e66c49b71 (patch)
tree0ebd5bedda7531179a58458bf9cbe0be48edb1fb
parentagent, sm: Set CTX after start_agent. (diff)
downloadgnupg-2b23a321ac0b07beeac1dfa8d71f223e66c49b71.tar.gz
gnupg-2b23a321ac0b07beeac1dfa8d71f223e66c49b71.zip
common: Correctly handle modules relying on npth.
* common/Makefile.am (common_sources): Drop 'call-gpg.{c,h}'. (with_npth_sources): New variable. (libcommonpth_a_SOURCES): Use the new variable. Signed-off-by: Justus Winter <[email protected]>
Diffstat (limited to '')
-rw-r--r--common/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
index 422fcf60a..9f151f250 100644
--- a/common/Makefile.am
+++ b/common/Makefile.am
@@ -88,7 +88,6 @@ common_sources = \
helpfile.c \
mkdir_p.c mkdir_p.h \
strlist.c strlist.h \
- call-gpg.c call-gpg.h \
exectool.c exectool.h \
server-help.c server-help.h \
name-value.c name-value.h \
@@ -114,11 +113,14 @@ endif
without_npth_sources = \
get-passphrase.c get-passphrase.h
+# Sources only useful with NPTH.
+with_npth_sources = \
+ call-gpg.c call-gpg.h
libcommon_a_SOURCES = $(common_sources) $(without_npth_sources)
libcommon_a_CFLAGS = $(AM_CFLAGS) $(LIBASSUAN_CFLAGS) -DWITHOUT_NPTH=1
-libcommonpth_a_SOURCES = $(common_sources)
+libcommonpth_a_SOURCES = $(common_sources) $(with_npth_sources)
libcommonpth_a_CFLAGS = $(AM_CFLAGS) $(LIBASSUAN_CFLAGS) $(NPTH_CFLAGS)
if !HAVE_W32CE_SYSTEM