aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustus Winter <[email protected]>2017-03-28 10:07:32 +0000
committerJustus Winter <[email protected]>2017-03-28 10:11:03 +0000
commit211d71f19c24da94f4c58014606125c1a29d86a2 (patch)
tree6869d0a2559211bdfd12ac937df438fef1bae364
parentg10: Fix memory leak. (diff)
downloadgnupg-211d71f19c24da94f4c58014606125c1a29d86a2.tar.gz
gnupg-211d71f19c24da94f4c58014606125c1a29d86a2.zip
tests: Add test for '--decrypt --unwrap'.
* tests/openpgp/Makefile.am (XTESTS): Add new test. * tests/openpgp/decrypt-unwrap-verify.scm: New file. Signed-off-by: Justus Winter <[email protected]>
Diffstat (limited to '')
-rw-r--r--tests/openpgp/Makefile.am1
-rwxr-xr-xtests/openpgp/decrypt-unwrap-verify.scm41
2 files changed, 42 insertions, 0 deletions
diff --git a/tests/openpgp/Makefile.am b/tests/openpgp/Makefile.am
index 518af200c..1a80bb6c9 100644
--- a/tests/openpgp/Makefile.am
+++ b/tests/openpgp/Makefile.am
@@ -48,6 +48,7 @@ XTESTS = \
decrypt-multifile.scm \
decrypt-dsa.scm \
decrypt-session-key.scm \
+ decrypt-unwrap-verify.scm \
sigs.scm \
sigs-dsa.scm \
encrypt.scm \
diff --git a/tests/openpgp/decrypt-unwrap-verify.scm b/tests/openpgp/decrypt-unwrap-verify.scm
new file mode 100755
index 000000000..97a72e4c7
--- /dev/null
+++ b/tests/openpgp/decrypt-unwrap-verify.scm
@@ -0,0 +1,41 @@
+#!/usr/bin/env gpgscm
+
+;; Copyright (C) 2017 g10 Code GmbH
+;;
+;; This file is part of GnuPG.
+;;
+;; GnuPG is free software; you can redistribute it and/or modify
+;; it under the terms of the GNU General Public License as published by
+;; the Free Software Foundation; either version 3 of the License, or
+;; (at your option) any later version.
+;;
+;; GnuPG is distributed in the hope that it will be useful,
+;; but WITHOUT ANY WARRANTY; without even the implied warranty of
+;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;; GNU General Public License for more details.
+;;
+;; You should have received a copy of the GNU General Public License
+;; along with this program; if not, see <http://www.gnu.org/licenses/>.
+
+(load (with-path "defs.scm"))
+(setup-legacy-environment)
+
+(lettmp (steve's-key)
+ (call-check `(,@gpg --output ,steve's-key --export "1D777619BE310D79"))
+
+ (for-each-p
+ "Checking unwrapping the encryption."
+ (lambda (name)
+ ;; First, unwrap the encrypted message using Steve's secret key.
+ (lettmp (unwrapped)
+ (tr:do
+ (tr:open (in-srcdir "samplemsgs" (string-append name ".asc")))
+ (tr:gpg "" `(--yes --decrypt --unwrap))
+ (tr:write-to unwrapped))
+
+ ;; Then, verify the signature with a clean working directory
+ ;; containing only Steve's public key.
+ (with-ephemeral-home-directory
+ (call-check `(,@gpg --import ,steve's-key))
+ (call-check `(,@gpg --verify ,unwrapped)))))
+ '("encsig-2-keys-3" "encsig-2-keys-4")))