aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2003-09-04 12:27:33 +0000
committerDavid Shaw <[email protected]>2003-09-04 12:27:33 +0000
commit192520ade6591f4ba032b7aea7460e01463175f7 (patch)
tree0f9c23b3badfcb563acf17000aa2779ea0b3f3a7
parent* mds.test, sigs.test: Remove TIGER/192 and make SHA-256 optional (since (diff)
downloadgnupg-192520ade6591f4ba032b7aea7460e01463175f7.tar.gz
gnupg-192520ade6591f4ba032b7aea7460e01463175f7.zip
* configure.ac: Drop TIGER/192 support. Check for UINT64_C to go along
with uint64_t.
Diffstat (limited to '')
-rw-r--r--ChangeLog5
-rw-r--r--configure.ac55
2 files changed, 16 insertions, 44 deletions
diff --git a/ChangeLog b/ChangeLog
index a1b010e85..77a5f9055 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,8 @@
+2003-09-04 David Shaw <[email protected]>
+
+ * configure.ac: Drop TIGER/192 support. Check for UINT64_C to go
+ along with uint64_t.
+
2003-09-01 David Shaw <[email protected]>
* NEWS: Note --list-options, --verify-options, the deprecation of
diff --git a/configure.ac b/configure.ac
index c8fe36a6c..c37c61aa2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -113,8 +113,6 @@ use_cast5=yes
use_blowfish=yes
use_aes=yes
use_twofish=yes
-use_tiger192=no
-use_old_tiger192=no
use_sha256=yes
use_sha512=yes
use_exec=yes
@@ -193,34 +191,6 @@ if test x"$use_twofish" = xyes ; then
AC_DEFINE(USE_TWOFISH,1,[Define to include the TWOFISH cipher])
fi
-dnl this is because the stable branch calls it just "tiger".
-AC_ARG_ENABLE(tiger,,use_tiger192=$enableval)
-AC_ARG_ENABLE(old-tiger,,use_old_tiger192=$enableval)
-
-dnl TIGER192 is actually defined only after we confirm 64-bit support
-dnl later
-AC_MSG_CHECKING([whether to enable the nonstandard TIGER/192 digest])
-AC_ARG_ENABLE(tiger192,
- AC_HELP_STRING([--enable-tiger192],[enable the nonstandard TIGER/192 digest]),
- use_tiger192=$enableval)
-AC_MSG_RESULT($use_tiger192)
-
-AC_MSG_CHECKING([whether to enable old-style nonstandard TIGER/192 digest support])
-AC_ARG_ENABLE(old-tiger192,
- AC_HELP_STRING([--enable-old-tiger192],[enable old-style nonstandard TIGER/192 digest support]),
- use_old_tiger=$enableval)
-AC_MSG_RESULT($use_old_tiger192)
-
-if test x"$use_tiger192" = xyes || test x"$use_old_tiger192" = xyes ; then
- AC_MSG_WARN([[
-***
-*** The TIGER/192 digest is in the process of being removed from the
-*** OpenPGP standard. While it hasn't been removed from GnuPG yet, it
-*** will be removed in a future version. For the sake of future
-*** compatibility, please do not use this digest.
-***]])
-fi
-
AC_MSG_CHECKING([whether to enable the SHA-256 digest])
AC_ARG_ENABLE(sha256,
AC_HELP_STRING([--disable-sha256],[disable the SHA-256 digest]),
@@ -692,7 +662,15 @@ AC_CHECK_SIZEOF(unsigned short)
AC_CHECK_SIZEOF(unsigned int)
AC_CHECK_SIZEOF(unsigned long)
AC_CHECK_SIZEOF(unsigned long long)
-AC_CHECK_SIZEOF(uint64_t)
+
+# Ensure that we have UINT64_C before we bother to check for uint64_t
+AC_CACHE_CHECK([for UINT64_C],[gnupg_cv_uint64_c_works],
+ AC_COMPILE_IFELSE(AC_LANG_PROGRAM([#include <inttypes.h>
+uint64_t foo=UINT64_C(42);]),gnupg_cv_uint64_c_works=yes,gnupg_cv_uint64_c_works=no))
+
+if test "$gnupg_cv_uint64_c_works" = "yes" ; then
+ AC_CHECK_SIZEOF(uint64_t)
+fi
if test "$ac_cv_sizeof_unsigned_short" = "0" \
|| test "$ac_cv_sizeof_unsigned_int" = "0" \
@@ -704,20 +682,9 @@ dnl Do we have any 64-bit data types?
if test "$ac_cv_sizeof_unsigned_int" != "8" \
&& test "$ac_cv_sizeof_unsigned_long" != "8" \
&& test "$ac_cv_sizeof_unsigned_long_long" != "8" \
- && test "$ac_cv_sizeof_uint64_t" != "8"; then
- AC_MSG_WARN([No 64-bit types. Disabling TIGER/192, SHA-384, and SHA-512])
+ && test x"$ac_cv_sizeof_uint64_t" != "x8"; then
+ AC_MSG_WARN([No 64-bit types. Disabling SHA-384 and SHA-512])
else
- if test x"$use_tiger192" = xyes ; then
- AC_SUBST(TIGER_O,tiger.o)
- AC_DEFINE(USE_TIGER192,1,[Define to include the TIGER/192 digest])
- fi
-
- if test "$use_old_tiger192" = yes ; then
- AC_SUBST(TIGER_O,tiger.o)
- AC_DEFINE(USE_TIGER192,1,[Define to include the TIGER/192 digest])
- AC_DEFINE(USE_OLD_TIGER,1,[Define to use the old fake OID for TIGER/192 digest support])
- fi
-
if test x"$use_sha512" = xyes ; then
AC_SUBST(SHA512_O,sha512.o)
AC_DEFINE(USE_SHA512,1,[Define to include the SHA-384 and SHA-512 digests])