aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2005-03-17 04:09:37 +0000
committerDavid Shaw <[email protected]>2005-03-17 04:09:37 +0000
commit166876a9fdb0c082c84007f5bd77097bf498e753 (patch)
treeffdcd92f95cfe863accdc0bb5fd5f02f9ca15149
parent* ldap.m4: New. Moved from configure.ac. (diff)
downloadgnupg-166876a9fdb0c082c84007f5bd77097bf498e753.tar.gz
gnupg-166876a9fdb0c082c84007f5bd77097bf498e753.zip
* configure.ac: Move the LDAP detecting code to m4/ldap.m4.
Diffstat (limited to '')
-rw-r--r--ChangeLog4
-rw-r--r--NEWS6
-rw-r--r--configure.ac64
3 files changed, 10 insertions, 64 deletions
diff --git a/ChangeLog b/ChangeLog
index e68919130..cba26952c 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,7 @@
+2005-03-16 David Shaw <[email protected]>
+
+ * configure.ac: Move the LDAP detecting code to m4/ldap.m4.
+
2005-03-15 Werner Koch <[email protected]>
Released 1.4.1.
diff --git a/NEWS b/NEWS
index 575e17d32..6a58be674 100644
--- a/NEWS
+++ b/NEWS
@@ -12,9 +12,9 @@ Noteworthy changes in version 1.4.1 (2005-03-15)
<http://lists.gnupg.org/pipermail/gnupg-users/2005-January/024408.html>.
* New "import-unusable-sigs" and "export-unusable-sigs" tags for
- --import-options and --export-options. These are off by
- default, and cause GnuPG to not import or export key signatures
- that are not usable (e.g. expired signatures).
+ --import-options and --export-options. These are off by default,
+ which causes GnuPG to not import or export key signatures that
+ are not usable (e.g. expired signatures).
* New experimental HTTP, HTTPS, FTP, and FTPS keyserver helper
that uses the cURL library <http://curl.haxx.se> to retrieve
diff --git a/configure.ac b/configure.ac
index d6ef7c83f..7c91ddcce 100644
--- a/configure.ac
+++ b/configure.ac
@@ -443,7 +443,6 @@ AC_PATH_PROG(PERL,"perl")
AC_ISC_POSIX
AC_SYS_LARGEFILE
AC_PROG_INSTALL
-AC_PROG_LN_S
AC_PROG_AWK
AC_CHECK_PROG(DOCBOOK_TO_MAN, docbook-to-man, yes, no)
AM_CONDITIONAL(HAVE_DOCBOOK_TO_MAN, test "$ac_cv_prog_DOCBOOK_TO_MAN" = yes)
@@ -452,7 +451,6 @@ GNUPG_CHECK_DOCBOOK_TO_TEXI
MPI_OPT_FLAGS=""
-
try_gettext=yes
have_dosish_system=no
need_dlopen=yes
@@ -594,69 +592,13 @@ fi
AC_SUBST(SRVLIBS)
-# Try and link a LDAP test program to weed out unusable LDAP
-# libraries. -lldap [-llber [-lresolv]] is for older OpenLDAPs.
-# OpenLDAP, circa 1999, was terrible with creating weird dependencies.
-# This seems to have all been resolved, so I'm simplifying this code
-# significantly. If all else fails, the user can play
-# guess-the-dependency by using something like ./configure
-# LDAPLIBS="-Lfoo -lbar"
+# Check for LDAP
if test "$try_ldap" = yes ; then
-
- AC_ARG_WITH(ldap,
- AC_HELP_STRING([--with-ldap=DIR],[look for the LDAP library in DIR]),
- [
- if test -d "$withval" ; then
- CPPFLAGS="${CPPFLAGS} -I$withval/include"
- LDFLAGS="${LDFLAGS} -L$withval/lib"
- fi
- ])
-
- for MY_LDAPLIBS in ${LDAPLIBS+"$LDAPLIBS"} "-lldap" "-lldap -llber" "-lldap -llber -lresolv" "-lwldap32"; do
- _ldap_save_libs=$LIBS
- LIBS="$MY_LDAPLIBS $NETLIBS $LIBS"
-
- AC_MSG_CHECKING([whether LDAP via \"$MY_LDAPLIBS\" is present and sane])
- AC_TRY_LINK([
-#ifdef _WIN32
-#include <winsock2.h>
-#include <winldap.h>
-#else
-#include <ldap.h>
-#endif
-],[ldap_open("foobar",1234);],
- [gnupg_cv_func_ldap_init=yes],[gnupg_cv_func_ldap_init=no])
- AC_MSG_RESULT([$gnupg_cv_func_ldap_init])
-
- if test "$gnupg_cv_func_ldap_init" = yes ; then
- LDAPLIBS=$MY_LDAPLIBS
- GPGKEYS_LDAP="gpgkeys_ldap$EXEEXT"
-
- AC_CHECK_FUNCS(ldap_get_option ldap_set_option ldap_start_tls_s)
-
- if test "$ac_cv_func_ldap_get_option" != yes ; then
- AC_MSG_CHECKING([whether LDAP supports ld_errno])
- AC_TRY_LINK([#include <ldap.h>],[LDAP *ldap; ldap->ld_errno;],
- [gnupg_cv_func_ldap_ld_errno=yes],
- [gnupg_cv_func_ldap_ld_errno=no])
- AC_MSG_RESULT([$gnupg_cv_func_ldap_ld_errno])
-
- if test "$gnupg_cv_func_ldap_ld_errno" = yes ; then
- AC_DEFINE(HAVE_LDAP_LD_ERRNO,1,[Define if the LDAP library supports ld_errno])
- fi
- fi
- fi
-
- LIBS=$_ldap_save_libs
-
- if test "$GPGKEYS_LDAP" != "" ; then break; fi
- done
+ GNUPG_CHECK_LDAP($NETLIBS)
fi
-AC_SUBST(GPGKEYS_LDAP)
-AC_SUBST(LDAPLIBS)
-AM_CONDITIONAL(GPGKEYS_LDAP, test "$GPGKEYS_LDAP" != "")
+# Special hack to test curl
AC_ARG_ENABLE(fake-curl,
AC_HELP_STRING([--enable-fake-curl],[enable EXPERIMENTAL no-curl HTTP code]),fake_curl=$enableval,fake_curl=no)