aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2005-05-06 13:03:22 +0000
committerDavid Shaw <[email protected]>2005-05-06 13:03:22 +0000
commit10f51e0714c9e96300a1a7fecacaf16ec7646859 (patch)
tree0d50cd39cb657f15a754a81272daea032da7a58a
parent* Makefile.am, packet.h, main.h, comment.c: Remove comment.c. We don't (diff)
downloadgnupg-10f51e0714c9e96300a1a7fecacaf16ec7646859.tar.gz
gnupg-10f51e0714c9e96300a1a7fecacaf16ec7646859.zip
* sign.c (sign_file, clearsign_file, sign_symencrypt_file): Use the
default sig expire value when signing in batchmode.
Diffstat (limited to '')
-rw-r--r--g10/ChangeLog5
-rw-r--r--g10/sign.c12
2 files changed, 11 insertions, 6 deletions
diff --git a/g10/ChangeLog b/g10/ChangeLog
index d7697af2f..c887a1bac 100644
--- a/g10/ChangeLog
+++ b/g10/ChangeLog
@@ -1,3 +1,8 @@
+2005-05-06 David Shaw <[email protected]>
+
+ * sign.c (sign_file, clearsign_file, sign_symencrypt_file): Use
+ the default sig expire value when signing in batchmode.
+
2005-05-05 David Shaw <[email protected]>
* Makefile.am, packet.h, main.h, comment.c: Remove comment.c. We
diff --git a/g10/sign.c b/g10/sign.c
index d3df1bf60..33a4c098c 100644
--- a/g10/sign.c
+++ b/g10/sign.c
@@ -744,9 +744,9 @@ sign_file( STRLIST filenames, int detached, STRLIST locusr,
&& (rc=setup_symkey(&efx.symkey_s2k,&efx.symkey_dek)))
goto leave;
- if(!opt.force_v3_sigs && !opt.batch && !RFC1991)
+ if(!opt.force_v3_sigs && !RFC1991)
{
- if(opt.ask_sig_expire)
+ if(opt.ask_sig_expire && !opt.batch)
duration=ask_expire_interval(1,opt.def_sig_expire);
else
duration=parse_expire_string(opt.def_sig_expire)*86400L;
@@ -1014,9 +1014,9 @@ clearsign_file( const char *fname, STRLIST locusr, const char *outfile )
memset( &afx, 0, sizeof afx);
init_packet( &pkt );
- if(!opt.force_v3_sigs && !opt.batch && !RFC1991)
+ if(!opt.force_v3_sigs && !RFC1991)
{
- if(opt.ask_sig_expire)
+ if(opt.ask_sig_expire && !opt.batch)
duration=ask_expire_interval(1,opt.def_sig_expire);
else
duration=parse_expire_string(opt.def_sig_expire)*86400L;
@@ -1173,9 +1173,9 @@ sign_symencrypt_file (const char *fname, STRLIST locusr)
memset( &cfx, 0, sizeof cfx);
init_packet( &pkt );
- if(!opt.force_v3_sigs && !opt.batch && !RFC1991)
+ if(!opt.force_v3_sigs && !RFC1991)
{
- if(opt.ask_sig_expire)
+ if(opt.ask_sig_expire && !opt.batch)
duration=ask_expire_interval(1,opt.def_sig_expire);
else
duration=parse_expire_string(opt.def_sig_expire)*86400L;