aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2002-07-04 13:35:42 +0000
committerDavid Shaw <[email protected]>2002-07-04 13:35:42 +0000
commit107e4a3f58cb28e771d233e0ba87d38e94fa8336 (patch)
treed29932f0260ad2d31bfab5e04ea4ca4a00d97b91
parent* server.c (gpgsm_status2): Insert a blank between all optional (diff)
downloadgnupg-107e4a3f58cb28e771d233e0ba87d38e94fa8336.tar.gz
gnupg-107e4a3f58cb28e771d233e0ba87d38e94fa8336.zip
* README: Document --disable-exec, --disable-photo-viewers,
--disable-keyserver-helpers, --enable-exec-path, and --with-photo-viewer. * configure.ac: Add --with-photo-viewer to lock the viewer at compile time and --disable-keyserver-helpers and --disable-photo-viewers to allow disabling one without disabling the other.
Diffstat (limited to '')
-rw-r--r--ChangeLog9
-rw-r--r--README23
-rw-r--r--configure.ac98
3 files changed, 97 insertions, 33 deletions
diff --git a/ChangeLog b/ChangeLog
index f0cb83c57..9e7e4afb3 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,12 @@
+2002-07-04 David Shaw <[email protected]>
+
+ * README:
+
+ * configure.ac: Add --with-photo-viewer to lock the viewer at
+ compile time and --disable-keyserver-helpers and
+ --disable-photo-viewers to allow disabling one without disabling
+ the other.
+
2002-07-03 David Shaw <[email protected]>
* configure.ac: Allow setting USE_EXEC_PATH to lock the exec-path
diff --git a/README b/README
index 1e9f1b934..a683c2ae4 100644
--- a/README
+++ b/README
@@ -507,6 +507,29 @@
Do not use assembler modules. It is not possible
to use this on some CPU types.
+ --disable-exec
+ Disable all remote program execution. This
+ disables photo ID viewing as well as all keyserver
+ types aside from HKP.
+
+ --disable-photo-viewers
+ Disable only photo ID viewing.
+
+ --disable-keyserver-helpers
+ Disable only keyserver helpers (not including
+ HKP).
+
+ --enable-exec-path=PATH
+ Force the exec search path to be set to PATH.
+ Note that this only really applies to keyserver
+ helpers as the photo-viewer can include its own
+ path.
+
+ --with-photo-viewer=FIXED_VIEWER
+ Force the photo viewer to be FIXED_VIEWER and
+ disable any ability for the user to change it in
+ their options file.
+
Installation Problems
---------------------
diff --git a/configure.ac b/configure.ac
index 65bc08726..d8631d3a2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -122,48 +122,80 @@ fi
AC_MSG_CHECKING([whether to enable external program execution])
AC_ARG_ENABLE(exec,
- [ --disable-exec disable external program execution],
+ [ --disable-exec disable all external program execution],
use_exec=$enableval, use_exec=yes)
AC_MSG_RESULT($use_exec)
if test "$use_exec" = no ; then
- AC_DEFINE(NO_EXEC,1,[Define to disable external program execution])
+ AC_DEFINE(NO_EXEC,1,[Define to disable all external program execution])
fi
if test "$use_exec" = yes ; then
- AC_MSG_CHECKING([for a restricted exec-path])
- AC_ARG_WITH(exec-path,
- [ --with-exec-path=PATH restrict exec-path to PATH],
- [if test "$withval" = yes ; then
- withval=no
+ AC_MSG_CHECKING([whether to use a restricted exec-path])
+ AC_ARG_ENABLE(exec-path,
+ [ --enable-exec-path=PATH restrict exec-path to PATH],
+ [if test "$enableval" = yes ; then
+ enableval=no
else
- AC_DEFINE_UNQUOTED(USE_EXEC_PATH,"$withval",
- [restrict exec-path to this])
- fi],withval=no)
- AC_MSG_RESULT($withval)
-
- AC_MSG_CHECKING([whether LDAP keyserver support is requested])
- AC_ARG_ENABLE(ldap,
- [ --disable-ldap disable LDAP keyserver interface],
- try_ldap=$enableval, try_ldap=yes)
- AC_MSG_RESULT($try_ldap)
-
- AC_MSG_CHECKING([whether experimental external hkp keyserver support is requested])
- AC_ARG_ENABLE(external-hkp,
- [ --enable-external-hkp enable experimental external HKP keyserver interface],
- try_hkp=$enableval, try_hkp=no)
- AC_MSG_RESULT($try_hkp)
-
- if test "$try_hkp" = yes ; then
- GPGKEYS_HKP="gpgkeys_hkp"
- AC_DEFINE(USE_EXTERNAL_HKP,1,[define to use the experimental external HKP keyserver interface])
+ AC_DEFINE_UNQUOTED(USE_EXEC_PATH,"$enableval",
+ [if set, restrict exec-path to this value])
+ fi],enableval=no)
+ AC_MSG_RESULT($enableval)
+
+ AC_MSG_CHECKING([whether to enable photo ID viewing])
+ AC_ARG_ENABLE(photo-viewers,
+ [ --disable-photo-viewers disable photo ID viewers],
+ [if test "$enableval" = no ; then
+ AC_DEFINE(DISABLE_PHOTO_VIEWER,1,[define to disable photo viewing])
+ fi],enableval=yes)
+ gnupg_cv_enable_photo_viewers=$enableval
+ AC_MSG_RESULT($enableval)
+
+ if test "$gnupg_cv_enable_photo_viewers" = yes ; then
+ AC_MSG_CHECKING([whether to use a fixed photo ID viewer])
+ AC_ARG_WITH(photo-viewer,
+ [ --with-photo-viewer=FIXED_VIEWER set a fixed photo ID viewer],
+ [if test "$withval" != yes ; then
+ AC_DEFINE_UNQUOTED(FIXED_PHOTO_VIEWER,"$withval",
+ [if set, restrict photo-viewer to this])
+ fi],withval=no)
+ AC_MSG_RESULT($withval)
fi
- AC_MSG_CHECKING([whether email keyserver support is requested])
- AC_ARG_ENABLE(mailto,
- [ --disable-mailto disable email keyserver interface],
- try_mailto=$enableval, try_mailto=yes)
- AC_MSG_RESULT($try_mailto)
-fi
+ AC_MSG_CHECKING([whether to enable external keyserver helpers])
+ AC_ARG_ENABLE(keyserver-helpers,
+ [ --disable-keyserver-helpers disable all external keyserver support],
+ [if test "$enableval" = no ; then
+ AC_DEFINE(DISABLE_KEYSERVER_HELPERS,1,
+ [define to disable keyserver helpers])
+ fi],enableval=yes)
+ gnupg_cv_enable_keyserver_helpers=$enableval
+ AC_MSG_RESULT($enableval)
+
+ if test "$gnupg_cv_enable_keyserver_helpers" = yes ; then
+ AC_MSG_CHECKING([whether LDAP keyserver support is requested])
+ AC_ARG_ENABLE(ldap,
+ [ --disable-ldap disable LDAP keyserver interface],
+ try_ldap=$enableval, try_ldap=yes)
+ AC_MSG_RESULT($try_ldap)
+
+ AC_MSG_CHECKING([whether experimental external hkp keyserver support is requested])
+ AC_ARG_ENABLE(external-hkp,
+ [ --enable-external-hkp enable experimental external HKP keyserver interface],
+ try_hkp=$enableval, try_hkp=no)
+ AC_MSG_RESULT($try_hkp)
+
+ if test "$try_hkp" = yes ; then
+ GPGKEYS_HKP="gpgkeys_hkp"
+ AC_DEFINE(USE_EXTERNAL_HKP,1,[define to use the experimental external HKP keyserver interface])
+ fi
+
+ AC_MSG_CHECKING([whether email keyserver support is requested])
+ AC_ARG_ENABLE(mailto,
+ [ --disable-mailto disable email keyserver interface],
+ try_mailto=$enableval, try_mailto=yes)
+ AC_MSG_RESULT($try_mailto)
+ fi
+ fi
AC_MSG_CHECKING([whether included zlib is requested])
AC_ARG_WITH(included-zlib,