aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>1999-02-28 18:14:18 +0000
committerWerner Koch <[email protected]>1999-02-28 18:14:18 +0000
commit0f5bb383b58a46499ceb5da275a99be6e3b355e1 (patch)
tree9727d30a543f8b56f6c7b1b6ae706940034fd765
parentSee ChangeLog: Fri Feb 26 17:55:41 CET 1999 Werner Koch (diff)
downloadgnupg-0f5bb383b58a46499ceb5da275a99be6e3b355e1.tar.gz
gnupg-0f5bb383b58a46499ceb5da275a99be6e3b355e1.zip
See ChangeLog: Sun Feb 28 19:11:00 CET 1999 Werner Koch
Diffstat (limited to '')
-rw-r--r--ChangeLog4
-rw-r--r--TODO1
-rw-r--r--configure.in19
-rw-r--r--g10/ChangeLog12
-rw-r--r--g10/keyedit.c6
-rw-r--r--g10/keygen.c10
-rw-r--r--g10/keylist.c2
-rw-r--r--g10/mainproc.c1
8 files changed, 39 insertions, 16 deletions
diff --git a/ChangeLog b/ChangeLog
index 8565122ac..5b58729ff 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,7 @@
+Sun Feb 28 19:11:00 CET 1999 Werner Koch <[email protected]>
+
+ * configure.in (dld): Test disabled.
+
Fri Feb 26 17:55:41 CET 1999 Werner Koch <[email protected]>
* encode.c (encode_simple): temporary fix.
diff --git a/TODO b/TODO
index ce204f50c..9fd57194c 100644
--- a/TODO
+++ b/TODO
@@ -20,6 +20,7 @@
* when decryptiong multiple key: print a warning only if no usable pubkey
encrypt package was found. Extension: display a list of all recipients.
+ * Can't import ring1.pgp. Compressed keys? Should print a warning.
Nice to have
------------
diff --git a/configure.in b/configure.in
index 85be8d9bb..84fcbdb3b 100644
--- a/configure.in
+++ b/configure.in
@@ -245,14 +245,17 @@ if test "$try_dynload" = yes ; then
dnl work for freebsd
AC_DEFINE(DLSYM_NEEDS_UNDERSCORE)
use_gnupg_extensions=yes
- else
- AC_CHECK_LIB(dld,dld_link)
- if test "$ac_cv_lib_dld_dld_link" = "yes"; then
- AC_DEFINE(USE_DYNAMIC_LINKING)
- AC_DEFINE(HAVE_DLD_DLD_LINK)
- DYNLINK_LDFLAGS="$CFLAGS_RDYNAMIC"
- use_gnupg_extensions=yes
- fi
+dnl else
+dnl
+dnl DLD is not ready for use. So I better disable this test
+dnl
+dnl AC_CHECK_LIB(dld,dld_link)
+dnl if test "$ac_cv_lib_dld_dld_link" = "yes"; then
+dnl AC_DEFINE(USE_DYNAMIC_LINKING)
+dnl AC_DEFINE(HAVE_DLD_DLD_LINK)
+dnl DYNLINK_LDFLAGS="$CFLAGS_RDYNAMIC"
+dnl use_gnupg_extensions=yes
+dnl fi
fi
fi
else
diff --git a/g10/ChangeLog b/g10/ChangeLog
index 0b89f6da8..11636394a 100644
--- a/g10/ChangeLog
+++ b/g10/ChangeLog
@@ -1,3 +1,15 @@
+Sun Feb 28 19:11:00 CET 1999 Werner Koch <[email protected]>
+
+ * keygen.c (ask_user_id): Don't change the case of email addresses.
+ (has_invalid_email_chars): Adjusted.
+
+ * keylist.c (list_one): Really list serect keys (Remi Guyomarch)
+
+ * keyedit.c (menu_select_uid): Add some braces to make egcs happy.
+ (menu_select_key): Ditto.
+
+ * mainproc.c (do_proc_packets): List sym-enc packets (Remi Guyomarch)
+
Fri Feb 26 17:55:41 CET 1999 Werner Koch <[email protected]>
* pkclist.c (build_pk_list): Return error if there are no recipients.
diff --git a/g10/keyedit.c b/g10/keyedit.c
index f6e06c036..f16a19cb6 100644
--- a/g10/keyedit.c
+++ b/g10/keyedit.c
@@ -1337,11 +1337,12 @@ menu_select_uid( KBNODE keyblock, int idx )
/* and toggle the new index */
for( i=0, node = keyblock; node; node = node->next ) {
if( node->pkt->pkttype == PKT_USER_ID ) {
- if( ++i == idx )
+ if( ++i == idx ) {
if( (node->flag & NODFLG_SELUID) )
node->flag &= ~NODFLG_SELUID;
else
node->flag |= NODFLG_SELUID;
+ }
}
}
@@ -1384,11 +1385,12 @@ menu_select_key( KBNODE keyblock, int idx )
for( i=0, node = keyblock; node; node = node->next ) {
if( node->pkt->pkttype == PKT_PUBLIC_SUBKEY
|| node->pkt->pkttype == PKT_SECRET_SUBKEY ) {
- if( ++i == idx )
+ if( ++i == idx ) {
if( (node->flag & NODFLG_SELKEY) )
node->flag &= ~NODFLG_SELKEY;
else
node->flag |= NODFLG_SELKEY;
+ }
}
}
diff --git a/g10/keygen.c b/g10/keygen.c
index dd812e729..1e40186c9 100644
--- a/g10/keygen.c
+++ b/g10/keygen.c
@@ -555,17 +555,18 @@ static int
has_invalid_email_chars( const char *s )
{
int at_seen=0;
+ static char valid_chars[] = "01234567890_-."
+ "abcdefghijklmnopqrstuvwxyz"
+ "ABCDEFGHIJKLMNOPQRSTUVWXYZ";
for( ; *s; s++ ) {
if( *s & 0x80 )
return 1;
if( *s == '@' )
at_seen=1;
- else if( !at_seen
- && !strchr("01234567890abcdefghijklmnopqrstuvwxyz_-.+", *s ))
+ else if( !at_seen && !( !!strchr( valid_chars, *s ) || *s == '+' ) )
return 1;
- else if( at_seen
- && !strchr("01234567890abcdefghijklmnopqrstuvwxyz_-.", *s ) )
+ else if( at_seen && !strchr( valid_chars, *s ) )
return 1;
}
return 0;
@@ -608,7 +609,6 @@ ask_user_id( int mode )
m_free(amail);
amail = cpr_get("keygen.email",_("Email address: "));
trim_spaces(amail);
- strlwr(amail);
cpr_kill_prompt();
if( !*amail )
break; /* no email address is okay */
diff --git a/g10/keylist.c b/g10/keylist.c
index a5456d52d..1861cd824 100644
--- a/g10/keylist.c
+++ b/g10/keylist.c
@@ -132,7 +132,7 @@ list_one( STRLIST names, int secret )
}
do {
merge_keys_and_selfsig( keyblock );
- list_keyblock( keyblock, 0 );
+ list_keyblock( keyblock, 1 );
release_kbnode( keyblock );
} while( !get_seckey_next( ctx, NULL, &keyblock ) );
get_seckey_end( ctx );
diff --git a/g10/mainproc.c b/g10/mainproc.c
index 7f3d3745e..fcb9f5db5 100644
--- a/g10/mainproc.c
+++ b/g10/mainproc.c
@@ -740,6 +740,7 @@ do_proc_packets( CTX c, IOBUF a )
if( opt.list_packets ) {
switch( pkt->pkttype ) {
case PKT_PUBKEY_ENC: proc_pubkey_enc( c, pkt ); break;
+ case PKT_SYMKEY_ENC: proc_symkey_enc( c, pkt ); break;
case PKT_ENCRYPTED: proc_encrypted( c, pkt ); break;
case PKT_COMPRESSED: proc_compressed( c, pkt ); break;
default: newpkt = 0; break;