aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNIIBE Yutaka <[email protected]>2018-01-26 01:08:29 +0000
committerNIIBE Yutaka <[email protected]>2018-01-26 01:13:34 +0000
commit08e686a6a6d5bcb5410228b388745d09686b260c (patch)
treeb91514b92d8e6106e9e5d6b4348ca4280de2c121
parentdoc: Note --quick-gen-key as an alias for --quick-generate-key (diff)
downloadgnupg-08e686a6a6d5bcb5410228b388745d09686b260c.tar.gz
gnupg-08e686a6a6d5bcb5410228b388745d09686b260c.zip
agent: More fix for get_client_pid for portability.
* configure.ac: Check sys/ucred.h instead of ucred.h. * agent/command-ssh.c: Include sys/ucred.h. -- It's *BSD and macOS thing. Fixes-commit: f7f806afa5083617f4aba02fc3b285b06a7d73d4 Signed-off-by: NIIBE Yutaka <[email protected]>
Diffstat (limited to '')
-rw-r--r--agent/command-ssh.c4
-rw-r--r--configure.ac2
2 files changed, 3 insertions, 3 deletions
diff --git a/agent/command-ssh.c b/agent/command-ssh.c
index 9d45a1864..213f3f9f7 100644
--- a/agent/command-ssh.c
+++ b/agent/command-ssh.c
@@ -44,8 +44,8 @@
#include <sys/socket.h>
#include <sys/un.h>
#endif /*!HAVE_W32_SYSTEM*/
-#ifdef HAVE_UCRED_H
-#include <ucred.h>
+#ifdef HAVE_SYS_UCRED_H
+#include <sys/ucred.h>
#endif
#include "agent.h"
diff --git a/configure.ac b/configure.ac
index c3fce317d..424ce7be1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1278,7 +1278,7 @@ AC_HEADER_STDC
AC_CHECK_HEADERS([string.h unistd.h langinfo.h termio.h locale.h getopt.h \
pty.h utmp.h pwd.h inttypes.h signal.h sys/select.h \
stdint.h signal.h util.h libutil.h termios.h \
- ucred.h sys/sysmacros.h sys/mkdev.h])
+ sys/ucred.h sys/sysmacros.h sys/mkdev.h])
AC_HEADER_TIME