aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2004-12-21 23:40:51 +0000
committerDavid Shaw <[email protected]>2004-12-21 23:40:51 +0000
commit06c5da8d61293543ca824c25bc6df6001bd21937 (patch)
tree962892a29daa40ac14bc2b20dbe0b217c0deccd6
parentFTP keyserver support via gpgkeys_ftp. This is currently off by default. (diff)
downloadgnupg-06c5da8d61293543ca824c25bc6df6001bd21937.tar.gz
gnupg-06c5da8d61293543ca824c25bc6df6001bd21937.zip
As always, CVS leaves out the local directory?
Diffstat (limited to '')
-rw-r--r--ChangeLog5
-rw-r--r--configure.ac15
2 files changed, 20 insertions, 0 deletions
diff --git a/ChangeLog b/ChangeLog
index 4213450f6..6820a3def 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,8 @@
+2004-12-21 David Shaw <[email protected]>
+
+ * configure.ac: Add check for --enable-ftp. It is disabled by
+ default for now.
+
2004-12-18 David Shaw <[email protected]>
* configure.ac: Call the new GNUPG_CHECK_READLINE macro for
diff --git a/configure.ac b/configure.ac
index 8117b1ee2..73a233175 100644
--- a/configure.ac
+++ b/configure.ac
@@ -323,6 +323,13 @@ dnl LDAP is defined only after we confirm the library is available later
try_finger=$enableval, try_finger=yes)
AC_MSG_RESULT($try_finger)
+ AC_MSG_CHECKING([whether ftp key fetching support is requested])
+ AC_ARG_ENABLE(ftp,
+ AC_HELP_STRING([--enable-ftp],
+ [enable ftp key fetching interface only]),
+ try_ftp=$enableval, try_ftp=no)
+ AC_MSG_RESULT($try_ftp)
+
AC_MSG_CHECKING([whether email keyserver support is requested])
AC_ARG_ENABLE(mailto,
AC_HELP_STRING([--disable-mailto],
@@ -641,6 +648,14 @@ AC_SUBST(GPGKEYS_LDAP)
AC_SUBST(LDAPLIBS)
AM_CONDITIONAL(GPGKEYS_LDAP, test "$GPGKEYS_LDAP" != "")
+if test "$try_ftp" = yes ; then
+ GNUPG_CHECK_LIBCURL
+
+ if test x"$have_libcurl" = xyes ; then
+ AC_SUBST(GPGKEYS_FTP,"gpgkeys_ftp$EXEEXT")
+ fi
+fi
+
dnl This isn't necessarily sendmail itself, but anything that gives a
dnl sendmail-ish interface to the outside world. That includes qmail,
dnl postfix, etc. Basically, anything that can handle "sendmail -t".