aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2003-10-24 16:57:02 +0000
committerWerner Koch <[email protected]>2003-10-24 16:57:02 +0000
commit068358616f5edc2a6c52da906d81210176ebce58 (patch)
tree817c98136b37bb4de5e5792f55ac14ea40413baa
parent(lock_pool) [_AIX]: Don't use plock. (diff)
downloadgnupg-068358616f5edc2a6c52da906d81210176ebce58.tar.gz
gnupg-068358616f5edc2a6c52da906d81210176ebce58.zip
(DLLIBS): Fixed last change.
Diffstat (limited to '')
-rw-r--r--ChangeLog4
-rw-r--r--configure.ac54
2 files changed, 30 insertions, 28 deletions
diff --git a/ChangeLog b/ChangeLog
index dda3ccd51..8b9482850 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,7 @@
+2003-10-24 Werner Koch <[email protected]>
+
+ * configure.ac (DLLIBS): Fixed last change.
+
2003-10-23 Werner Koch <[email protected]>
* configure.ac (DLLIBS): Do not include -ldl in the mingw32 case.
diff --git a/configure.ac b/configure.ac
index 9b915578f..71d01dc91 100644
--- a/configure.ac
+++ b/configure.ac
@@ -344,6 +344,7 @@ MPI_OPT_FLAGS=""
try_gettext=yes
have_dosish_system=no
+no_need_for_dlopen=no
case "${target}" in
*-*-mingw32*)
# special stuff for Windoze NT
@@ -357,6 +358,7 @@ case "${target}" in
MingW32 systems and these systems lack Posix functions,
we use a simplified version of gettext])
have_dosish_system=yes
+ no_need_for_dlopen=yes
try_gettext="no"
;;
i?86-emx-os2 | i?86-*-os2*emx )
@@ -630,38 +632,34 @@ else
fi
if test "$try_extensions" = yes || test x"$card_support" = xyes ; then
- AC_CHECK_FUNC(dlopen,,AC_CHECK_LIB(dl,dlopen,found_dlopen=yes))
- if test x"$found_dlopen" = "xyes" ; then
- AC_DEFINE(HAVE_DL_DLOPEN,1,
- [Defined when the dlopen function family is available])
- case "${target}" in
- *-*-mingw32*)
- ;;
- *)
- AC_SUBST(DLLIBS,"-ldl")
- ;;
- esac
-
- if test "$try_extensions" = yes ; then
- AC_DEFINE(USE_DYNAMIC_LINKING,1,
- [define to enable the use of extensions])
- fi
-
- if test "$card_support" = yes ; then
- AC_DEFINE(ENABLE_CARD_SUPPORT,1,
- [Define to include the OpenPGP card support])
- fi
+ if test "$no_need_for_dlopen" = yes; then
+ AC_SUBST(DLLIBS,"")
else
- if test "$try_extensions" = yes ; then
- AC_MSG_WARN([dlopen not found. Disabling extensions.])
- fi
-
- if test "$card_support" = yes ; then
- AC_MSG_WARN([dlopen not found. Disabling OpenPGP card support.])
- card_support=no
+ AC_CHECK_FUNC(dlopen,,AC_CHECK_LIB(dl,dlopen,found_dlopen=yes))
+ if test x"$found_dlopen" = "xyes" ; then
+ AC_DEFINE(HAVE_DL_DLOPEN,1,
+ [Defined when the dlopen function family is available])
+ AC_SUBST(DLLIBS,"-ldl")
+ if test "$try_extensions" = yes ; then
+ AC_DEFINE(USE_DYNAMIC_LINKING,1,
+ [define to enable the use of extensions])
+ fi
+ else
+ if test "$try_extensions" = yes ; then
+ AC_MSG_WARN([dlopen not found. Disabling extensions.])
+ fi
+
+ if test "$card_support" = yes ; then
+ AC_MSG_WARN([dlopen not found. Disabling OpenPGP card support.])
+ card_support=no
+ fi
fi
fi
fi
+if test "$card_support" = yes ; then
+ AC_DEFINE(ENABLE_CARD_SUPPORT,1,
+ [Define to include the OpenPGP card support])
+fi
AM_CONDITIONAL(ENABLE_CARD_SUPPORT, test "$card_support" = yes)