diff options
author | David Shaw <[email protected]> | 2002-10-02 20:05:37 +0000 |
---|---|---|
committer | David Shaw <[email protected]> | 2002-10-02 20:05:37 +0000 |
commit | 05e894545ca1cd0d49feb0925c129e82a8f44eb0 (patch) | |
tree | c3466fa322a2be621f89e2a8257f8eae239b6aec | |
parent | * tiger.c (tiger_get_info): Select the OID to use for TIGER at compile (diff) | |
download | gnupg-05e894545ca1cd0d49feb0925c129e82a8f44eb0.tar.gz gnupg-05e894545ca1cd0d49feb0925c129e82a8f44eb0.zip |
* configure.ac: Add an --enable-old-tiger, to revert back to the
old OID.
Diffstat (limited to '')
-rw-r--r-- | ChangeLog | 5 | ||||
-rw-r--r-- | configure.ac | 9 |
2 files changed, 14 insertions, 0 deletions
@@ -1,3 +1,8 @@ +2002-10-02 David Shaw <[email protected]> + + * configure.ac: Add an --enable-old-tiger, to revert back to the + old OID. + 2002-09-27 David Shaw <[email protected]> * configure.ac: Remove --enable-tiger, as TIGER is now always diff --git a/configure.ac b/configure.ac index 26c5bdd3a..43f3f8536 100644 --- a/configure.ac +++ b/configure.ac @@ -135,6 +135,15 @@ if test "$use_m_guard" = yes ; then AC_DEFINE(M_GUARD,1,[Define to use the (obsolete) malloc guarding feature]) fi +AC_MSG_CHECKING([whether to enable old-style TIGER digest support]) +AC_ARG_ENABLE(old-tiger, + [ --enable-old-tiger enable old-style TIGER digest support], + old_tiger=$enableval, old_tiger=no) +AC_MSG_RESULT($old_tiger) +if test "$old_tiger" = yes ; then + AC_DEFINE(USE_OLD_TIGER,1,[Define to use the old fake OID for TIGER digest support]) +fi + AC_MSG_CHECKING([whether to enable external program execution]) AC_ARG_ENABLE(exec, [ --disable-exec disable all external program execution], |