aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2017-11-20 11:32:31 +0000
committerWerner Koch <[email protected]>2017-11-20 11:32:31 +0000
commit04d9833e71cc9d0c087faec091c29b0b6cf69488 (patch)
treea5f6cf895d58c7aedf38d37fcc9c7f9c899e6b2f
parentgpg-agent: Avoid getting stuck in shutdown pending state. (diff)
downloadgnupg-04d9833e71cc9d0c087faec091c29b0b6cf69488.tar.gz
gnupg-04d9833e71cc9d0c087faec091c29b0b6cf69488.zip
build: Use -Werror only for the check.
* configure.ac: Do not add -Werror to mycflags. -- On Windows and possible also on other platforms we expect to a get a few errors or warnins. Thus we can't use -Werror by default. This is why we have a separate configure options --enable-werror ;-). Fixes-commit: 3ecd1a41be7c880976987d13e88342c98f37e064 Signed-off-by: Werner Koch <[email protected]>
Diffstat (limited to '')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3d3a136b4..fb6f0da52 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1617,7 +1617,7 @@ if test "$GCC" = yes; then
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([],[])],_gcc_wopt=yes,_gcc_wopt=no)
AC_MSG_RESULT($_gcc_wopt)
if test x"$_gcc_wopt" = xyes ; then
- mycflags="$mycflags -Wlogical-op -Werror"
+ mycflags="$mycflags -Wlogical-op"
fi
AC_MSG_CHECKING([if gcc supports -Wvla])