aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2018-10-25 16:27:04 +0000
committerWerner Koch <[email protected]>2018-10-25 16:27:04 +0000
commit04604e6cb9999a1f29fcb6acfe2223981fd2cf4b (patch)
treeee4856b0ab7a528174578c7819a6c556dda46ef9
parentdirmngr: Fix out of scope use of a var in the keyserver LDAP code. (diff)
downloadgnupg-04604e6cb9999a1f29fcb6acfe2223981fd2cf4b.tar.gz
gnupg-04604e6cb9999a1f29fcb6acfe2223981fd2cf4b.zip
speedo: Sign the windows installer with a timestamp.
--
Diffstat (limited to '')
-rw-r--r--build-aux/speedo.mk10
1 files changed, 7 insertions, 3 deletions
diff --git a/build-aux/speedo.mk b/build-aux/speedo.mk
index 320d4403d..bfbce054d 100644
--- a/build-aux/speedo.mk
+++ b/build-aux/speedo.mk
@@ -157,8 +157,9 @@ INST_NAME=gnupg-w32
# Use this to override the installaion directory for native builds.
INSTALL_PREFIX=none
-# The Authenticode key used to sign the Windows installer
+# The Authenticode key and cert chain used to sign the Windows installer
AUTHENTICODE_KEY=${HOME}/.gnupg/g10code-authenticode-key.p12
+AUTHENTICODE_CERTS=${HOME}/.gnupg/g10code-authenticode-certs.pem
# Directory names.
@@ -1266,8 +1267,11 @@ sign-installer:
echo "speedo: * Signing installer" ;\
echo "speedo: * Key: $(AUTHENTICODE_KEY)";\
echo "speedo: */" ;\
- osslsigncode sign -pkcs12 $(AUTHENTICODE_KEY) -askpass \
- -h sha256 -in "PLAY/inst/$$exefile" -out "../../$$exefile" ;\
+ osslsigncode sign -certs $(AUTHENTICODE_CERTS)\
+ -pkcs12 $(AUTHENTICODE_KEY) -askpass \
+ -ts "http://timestamp.globalsign.com/scripts/timstamp.dll" \
+ -h sha256 -n GnuPG -i https://gnupg.org \
+ -in "PLAY/inst/$$exefile" -out "../../$$exefile" ;\
exefile="../../$$exefile" ;\
$(call MKSWDB_commands,$${exefile},$${reldate}); \
echo "speedo: /*" ;\