aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNIIBE Yutaka <[email protected]>2013-04-01 02:42:11 +0000
committerNIIBE Yutaka <[email protected]>2013-04-01 03:03:32 +0000
commit021767d8aa11aac8ac87dc3a31969ee6cfa65966 (patch)
treee1207312ed8d50eddb060d455e2ad2370cdd6bee
parentcopyright assignments are not anymore required. (diff)
downloadgnupg-021767d8aa11aac8ac87dc3a31969ee6cfa65966.tar.gz
gnupg-021767d8aa11aac8ac87dc3a31969ee6cfa65966.zip
scd: move SCDaemon to libexecdir.
* common/homedir.c (gnupg_module_name): It's now libexecdir. * scd/Makefile.am (libexec_PROGRAMS): Add scdaemon (bin_PROGRAMS): Remove scdaemon.
Diffstat (limited to '')
-rw-r--r--common/homedir.c2
-rw-r--r--scd/Makefile.am7
2 files changed, 5 insertions, 4 deletions
diff --git a/common/homedir.c b/common/homedir.c
index 6d0674911..28e5c9a2f 100644
--- a/common/homedir.c
+++ b/common/homedir.c
@@ -507,7 +507,7 @@ gnupg_module_name (int which)
#ifdef GNUPG_DEFAULT_SCDAEMON
return GNUPG_DEFAULT_SCDAEMON;
#else
- X(bindir, "scdaemon");
+ X(libexecdir, "scdaemon");
#endif
case GNUPG_MODULE_NAME_DIRMNGR:
diff --git a/scd/Makefile.am b/scd/Makefile.am
index a0c0369e7..1af13d0aa 100644
--- a/scd/Makefile.am
+++ b/scd/Makefile.am
@@ -19,9 +19,10 @@
EXTRA_DIST = ChangeLog-2011
-bin_PROGRAMS = scdaemon
-if ! HAVE_W32_SYSTEM
-libexec_PROGRAMS = gnupg-pcsc-wrapper
+if HAVE_W32_SYSTEM
+libexec_PROGRAMS = scdaemon
+else
+libexec_PROGRAMS = scdaemon gnupg-pcsc-wrapper
endif
AM_CPPFLAGS = -I$(top_srcdir)/gl -I$(top_srcdir)/intl -I$(top_srcdir)/common