aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ee3f5758..1f08f440 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -449,6 +449,10 @@ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DELPP_NO_DEFAULT_LOG_FILE")
# Introduce boost
if(NOT BOOST_ROOT)
find_package(Boost COMPONENTS date_time system REQUIRED)
+else()
+ find_package(Boost
+ COMPONENTS date_time system REQUIRED
+ PATHS ${BOOST_ROOT} NO_DEFAULT_PATH)
endif()
# Introduce OpenSSL