aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsaturneric <[email protected]>2024-07-12 12:53:16 +0000
committersaturneric <[email protected]>2024-07-12 12:58:34 +0000
commit9f61a1f86ca85da52a13a57290db95655cd5740e (patch)
tree16a5408934cdfb2fa8d59e38c707f374becd31c7 /CMakeLists.txt
parentfeat: move modules' code out of repo (diff)
downloadGpgFrontend-9f61a1f86ca85da52a13a57290db95655cd5740e.tar.gz
GpgFrontend-9f61a1f86ca85da52a13a57290db95655cd5740e.zip
feat: improve the project structure
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 76547e65..d0628ae3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -133,7 +133,7 @@ if (GPGFRONTEND_BUILD_TYPE_SDK)
unset(GPGFRONTEND_BUILD_CONFIG)
set(STABLE_BUILD_APPLICATION 0)
- set(BUILD_SDK 1)
+ set(STABLE_BUILD_SDK_ONLY 1)
endif()
# C++
@@ -371,10 +371,12 @@ if (STABLE_BUILD_APPLICATION)
set(BUILD_TEST 1)
set(BUILD_APPLICATION 1)
set(SUPPORT_MULTI_LANG 1)
-elseif (BUILD_SDK)
+ set(BUILD_SDK 1)
+elseif (STABLE_BUILD_SDK_ONLY)
message("[+] Build SDK")
set(BUILD_CORE 1)
set(BUILD_MODULE 1)
+ set(BUILD_SDK 1)
endif ()
# For instance in order to select the highest version one